Results 1 to 3 of 3
  1. #1

    Battery Drain after RED/PURPLE wire mod on SL 700

    So I did the Purple Wire nod on My SL 700 and now the battery dies over night. I charge it up and then it dies again. it was fine until the mod. Anyone else have this issue?

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Does your bilge pump work normally? On when button is pressed, and on whenever engine is running. Off when engine is off?

    Post a photo of the electrical box wiring after the modification.

  3. #3
    Yes the bilge works perfect. I will snap a picture after all this rain stops.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. battery drain article ??
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 1
    Last Post: 12-28-2007, 07:59 PM
  2. 02 GTXDI battery drain help Other
    By yacser1 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 10-11-2007, 10:28 PM
  3. new guy with purple hull raider
    By mach1charlie in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 07-25-2007, 09:36 PM
  4. Anyone heard of Royal Purple oil?
    By peteshauling in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 03-06-2007, 05:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts