Results 1 to 7 of 7

Thread: help slt 780

  1. #1
    primorxp's Avatar
    Join Date
    Jul 2009
    Location
    Saint Louis, Missouri, United States
    Posts
    415
    +1
    11

    help slt 780

    I have a 780 slt will idle wont rev up dull spark not bright as it should be plugs wet. whats up


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Have you trimmed the spark plug wires back 1/4 inch and rescrewed the plug caps on?

    After that, use a multimeter to ohm check the ignition wires and coils.

  3. #3
    primorxp's Avatar
    Join Date
    Jul 2009
    Location
    Saint Louis, Missouri, United States
    Posts
    415
    +1
    11
    did the plug wires and no change

    john

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Did you ohm test the stator and coils?

  5. #5
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    Quote Originally Posted by K447 View Post
    Have you trimmed the spark plug wires back 1/4 inch and rescrewed the plug caps on?
    I have seen other people talk about this. Do you have any further information on this like pics? So the plug caps screw on and are not crimped. Thanks for the help

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Unscrew the boots off.

    Clip the wires back about 1/4" to expose fresh wire.

    Rescrew the boots on.

    Install Zip ties to secure boots.

  7. #7
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    Found this link from K447 in another thread in case some one is visual like me.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780 help. Motor wont rev past 4000
    By nz253 in forum Polaris Open Discussion
    Replies: 32
    Last Post: 10-11-2015, 05:45 PM
  2. HELP PLEASE! 96' SLT 780 won't turn over
    By cnicholas in forum Polaris How To & FAQs
    Replies: 25
    Last Post: 06-20-2008, 10:52 PM
  3. HELP!! '96 780 SLT Quits......
    By moose42 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-06-2007, 09:44 PM
  4. Help, SLT 780 problem(s)
    By tcboss429 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-07-2007, 03:36 PM
  5. HELP slt 780
    By rbridges in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-04-2007, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •