Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30

    Chasing cavitation - starting teardown, questions

    Guys - i've pulled the nozzle off of my wifes 97 SPX in order to inspect some things in there to fix the cavitation issue it has.

    Also removed the intake grate and I can see the backside of the impeller as well as the driveshaft?

    I can wiggle the shaft up and down and there's a lot of play where the impeller is connected. I'm guessing this is the bad rattle that I have when the ski is shutting down, and probably isn't good.

    I have pictures coming, but for the time being can anyone shed light on what i'm seeing, what I should be looking for, etc...

    The backside of the impeller - very ends of the impeller are torn up pretty good, at least it looks like it to me.

    No idea if there's any oil in that cone yet, haven't pulled it.

    Symptoms - Slow to plane, sounds like it's hitting a rev limiter? (Do these have rev limiters?), vibration almost feels like a race car that has solid motor mounts, air sucking sound

    Runs ok when on plane, mild choppy water it hit 53mph yesterday - not sure where they're supposed to be but runs ok once moving.


  2. #2

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30
    Just got the nozzle off


    Broken piece on ride plate? Is this an issue?


    Impeller


    View from intake grate


    I can grab this nut and move it in and out about a 1/4" - meaning?


    The cone - has a spring in it

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    that prop is thoroughly trashed! plus your pump tunnel is severely damaged. you are also missing the nose cone that covers the drive shaft splines to the impeller.

    to pull the pump you have to disconnect the three lines inside the hull. one is the water in line and the other two are the bilge lines. do that and remove the 4 nuts holding the pump on and it will come off with a bit of muscle.

  4. #4

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30
    Pump is out - this seal was wasted








    Looks like I have some work to do.

    Wear ring, prop, pump rebuild, seal?, whatever is supposed to cover the splines of the impeller, etc....

  5. #5

    Join Date
    Apr 2005
    Location
    Upstate NY
    Posts
    37
    That spring in the cone (anti rattle update) preloads the impeller shaft and helps prevent a rather annoying "knock" at idle. Without it, the shaft moves back and forth and creates a knocking noise, which is harmless but bothersome.

    Yes, it sounds like a pump rebuild is in order. For the prop, I'd recommend a Solas XO if you don't mind spending a little more. It is superior to the stock prop. The neoprene pump seals can be found on online for $5-6, and pump rebuild kits (new bearings, seals) can be had for $45-50. If the impeller shaft is toasted, thats another $50-60.

    While you are at it you might think about pulling the drive shaft and reconditioning the carbon ring and collar (the stainless collar can be pushed in the direction of the pump and then you can remove the o-ring holding it in place) Get yourself some fine grit wet sandpaper (2000 grit) and polish up the mating surface on both the collar and carbon ring, using a level and flat surface. This will assure a good seal and should eliminate any remaining cavitation. Do a search for more info.

  6. #6

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30
    Gotcha - thanks for the info!

  7. #7
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    actually its easier to remove the carbon ring by reinstalling the pump. after you do go in the hull, compress the accordion boot to the rear of the ski to reveal the o ring on the drive shaft, slide/roll that forward. then the drive shaft will come out after you remove the pump again

  8. #8

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30
    What do you think of my parts list? Does it look like i'm on the right track with getting this back together? Not sure what the piece on the impeller is called - that covers the splines, any ideas?

  9. #9
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    bearing kit, wear ring, prop, updated carbon ring, impeller nose cone, new seal for the rear cone. you can find all these parts in the OEM parts finder tab at the top of the forum

  10. #10

    Join Date
    Apr 2005
    Location
    Upstate NY
    Posts
    37
    Quote Originally Posted by airbornexp View Post
    actually its easier to remove the carbon ring by reinstalling the pump. after you do go in the hull, compress the accordion boot to the rear of the ski to reveal the o ring on the drive shaft, slide/roll that forward. then the drive shaft will come out after you remove the pump again
    Sure, you should pop the collar before you pull the jet pump but the procedure is just as easy to perform with the pump removed.

    If you are going to do the rebuild yourself its time to pick up an impeller removal tool.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 FX HO cavitation problems / upgrade questions
    By factionfx in forum Yamaha PWC Performance (4-stroke)
    Replies: 23
    Last Post: 03-24-2012, 01:10 AM
  2. Just getting started, couple questions
    By ryanr623 in forum PWC Fishing
    Replies: 8
    Last Post: 07-02-2011, 12:07 PM
  3. found a "new" 98' STX 900, start-up question
    By TJBrad04 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 04-22-2009, 08:55 PM
  4. start button question for vintage XP
    By SideFX in forum 2-Stroke Performance
    Replies: 11
    Last Post: 02-28-2009, 11:45 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •