Results 1 to 8 of 8
  1. #1

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4

    Finaly in the water!

    Welllllll did some first time runs from doing all the stuff to the ski.. I got a ways to go in tuning still first runs are @ 74.8 MPH but RPM are low still gonna do a little prop work.
    Had the RIVA plate on the ski and ended up taken off. it was WAY to bouncy even shimmed.. stock plate handled so much better! prob gonna do some more FPR scale back & fine tune with powershot. ski is running rich in low & mid range..

    all in all not a REAL bad day speed is way low tho.. good that no issues came up with doing all this tho!

    Anyone else have a problem of bilge pump running always now after doing work?


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    The bilge should always run when the ski is turned on. Also, it should run for ~20 seconds after you shut the ski off or when you tap the start button.

  3. #3

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    well thats good to know.. I have never noticed before! then again never had the seat off when out before either... I did know it ran after the ski shut off..

    Thanks for that.. makes me feel better

  4. #4

    Join Date
    Jan 2009
    Location
    Qatar
    Posts
    63
    good job but why is the RIVA plate so bouncy !!! it should be good to go as it as ? i might get mine send to jim to fix it before it gets to me

  5. #5

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    Jerry said It was from the first batch. so it was prob one of the bad plates... hopefully gonna swap out for a new one and try maybe better luck...

  6. #6
    It is What it is! Bulldogs101's Avatar
    Join Date
    Nov 2007
    Location
    Southwest USA
    Posts
    222
    +1
    1
    very nice

  7. #7
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Very nice. What were your RPM's and was that with a (true) 13/23 Skat?

  8. #8

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    Well its a out of the box 13/23 I gotta pull the prop and send it to Jerry for some pitch work.. RPM 7800 12.5 lbs 74.8 max mph

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. keys in the water
    By Flying Scotsman in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 04-24-2007, 07:44 PM
  2. Coop is back in the Water !!!
    By RX951 in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 12-07-2006, 08:21 AM
  3. Finally...in the water!!
    By sourpower RXT in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-30-2006, 01:58 PM
  4. Hole shot won't stay in the water.
    By great lakes gpr 1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 04-19-2006, 08:28 PM
  5. Finally in the water
    By Sunfunzoom in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •