Results 1 to 5 of 5
  1. #1
    jcjw1998's Avatar
    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    13

    Pro 785 running very strange... please help

    I just got back from the lake and experienced something very weird with my pro 785. It runs perfect if I steer a little to the left but if I run straight or steer to the right it bogs down and falls on it's face. Has anyone ever experienced this and if so what in the world is the fix.

    Thanks guys!


  2. #2
    Hey John, it's Jay.

    Guys, I was out there with him yesterday, and that is the weirdest problem I have ever sen. It started with the fuse for the MFD being blown because it was blank. The ski was stuck in limp mode. Once we replaced the fuse it ran like a scalded dog. Talk about scary. It ran really low on fuel and after the ski was gassed back up that is when it started again. But when you turned left it went fine. It is acting like it is in limp mode again. We pulled the fuse on the mfd, and the put it back in, and it got better, but then started the problem all over again. We even used my MFD to see if it was that.

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    thats a lean bog try turning the highs out a bit

  4. #4
    jcjw1998's Avatar
    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    13
    Quote Originally Posted by friscoboater View Post
    Hey John, it's Jay.

    Guys, I was out there with him yesterday, and that is the weirdest problem I have ever sen. It started with the fuse for the MFD being blown because it was blank. The ski was stuck in limp mode. Once we replaced the fuse it ran like a scalded dog. Talk about scary. It ran really low on fuel and after the ski was gassed back up that is when it started again. But when you turned left it went fine. It is acting like it is in limp mode again. We pulled the fuse on the mfd, and the put it back in, and it got better, but then started the problem all over again. We even used my MFD to see if it was that.
    Jay,
    We missed you back at the lake on Sunday!! Man you will not believe what happened. We got the ski back on the water (after I flipped that head gasket over) and it ran good for about a minute then started running good only to the left again. We tore down the motor right there on the beach then put it back together with new plugs... now when we tried to start it the starter only engaged for about 2 seconds then the button would not do anything. I opened up the electrical box and immediately saw that there was something that should be bolted down that was just flopping around (dont know what it was) so I screwed it back down to the circuit board and the entire jet ski immediately ran like a scalded dog again for the rest of the weekend. That part must have been causing all the problems. When I would lean left it would connect but lose connection when upright or to the right. How strange! Oh well.. Thanks for all you help man and it was great meeting you.

  5. #5
    Man that is awesome. I am glad to see one of use had some luck this weekend. My SLX is trash now. The rod wrapped around the crank and split the case. Fun times.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. two skis = two problems. 1990 650 lx. very frustrated please help
    By bleedblue94 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 06-17-2013, 07:32 PM
  2. sxr 800 running like crap please help someone reply thanks
    By skidaddy o in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 05-28-2013, 02:38 AM
  3. Please help....97 pro 785 runs then dies
    By billybobtucson in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-30-2009, 12:48 AM
  4. 97 XP won't run under load please help
    By jared427 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-16-2009, 06:02 AM
  5. 97 pro 785 runs good out of water but not in
    By bidwell785 in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-16-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •