Results 1 to 9 of 9
  1. #1
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8

    RXTX 255 Cavatation

    Hi I had my first ride on my RXTX 255 today. One thing that bugged me was the pump cav out of the hole, since I got home I have pulled the pump took impeller out but everything looks ok. The only thing that Im not sure about is it had heaps of grease on the rubber ring that seals the pump to the boat, should it have grease on it?
    I have checked engine mounts all seem good.
    Another question is I feel the motor doesnt idle that smooth or not as smooth as I remember my RXP to be, its been a few years since I had a doo so Im trying to get up to speed with them again. Any ideas would be great. Thanks


  2. #2
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    i wouldnt say heaps of grease is normal but some/most do use a little grease to seal the pump into the pump shoe. and for what its worth i would say my px idles "smooth" either

  3. #3
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Quote Originally Posted by Mike H View Post
    i wouldnt say heaps of grease is normal but some/most do use a little grease to seal the pump into the pump shoe. and for what its worth i would say my px idles "smooth" either
    Do you mean you WOULD NOT say your px idles smooth?? Just making sure thanks.

  4. #4
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    I pulled the R&D intake grate off and found I had forgot to silicone the rear of the grate, I'm hoping this might be my cavitation problem. Anyone else had cavitation from a poorly sealed intake grate??

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Is this ski stock?

    Make sure the rideplate is sealed good behind the the intake grate. Check your tunnel is good/ok on the RXTX.

    I don't think greasing the o-ring is a good idea. Just wipe on a little silicone lube on the o-ring and install.

    May need some prop work.

    A set of DENSO plugs will smooth out the idle some.

  6. #6
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Interesting thanks will check out ride plate seal and Denso plugs. The ski is stock apart from Air Intake and R&D grate. Showing 8200 rpm is that about right?

  7. #7
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by fussy1 View Post
    Interesting thanks will check out ride plate seal and Denso plugs. The ski is stock apart from Air Intake and R&D grate. Showing 8200 rpm is that about right?
    No, you need prop work, if your wear ring and prop are in excellent shape. You are on the limiter. Should be shooting for 8080-8120.

  8. #8
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    What prop do you think would be the best? The thing pulls hard but seems alot of revs, I need to get a gps on it to.

  9. #9
    I replaced alot on mine until the rubber boot and carbon ring fixed it. Mainly the boot, it had weathered and got smaller.

    Bryan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Pro Pump Housing or the SS sleeve insert
    By Dazz67 in forum Polaris Classifieds
    Replies: 2
    Last Post: 07-05-2008, 10:13 AM
  2. Oil Pump Remove or Not
    By beerdart in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 08-19-2007, 01:37 PM
  3. What To Align First, Pump Shoe or Engine?
    By yellow4 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-27-2007, 07:12 AM
  4. slipping or cavitating
    By bobbysmith in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-20-2007, 07:34 AM
  5. HELP on (oil pump) in or out?
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 01-12-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •