Results 1 to 10 of 10
  1. #1
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169

    Cant pass 10 mph ???

    98 seadoo spx

    On water:
    Ski starts and idles fine but has no power.
    When I hit the gas it doesnít seem 2 rev at all
    I canít pass 10mph



    On land:
    Ski starts and idles fine.
    When I hit the gas it seems 2 rev up nice and high
    Once I put the flush hose on it, it wants 2 stall.
    I didnít notice it pissing out water with the flush hose on it.. I thought seadooís shoot water out straight out of the back


    Attempted fixes:
    Rebuilt the carbs to find the same problem


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,259
    +1
    117
    it wanting to stall when you put the hose on it is not good. and yes you should have a pisser right below the rear towhook. it sounds like you have a water leak somewhere.

  3. #3
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    anyone have ideas on where i should look?

  4. #4
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    Bump

  5. #5
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    Bump

    cant afford a shop at the moment

  6. #6
    did you change fuel lines, did you clean petcock out??and all fittings where fuel hose barbs are??>Marvin

  7. #7
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060
    Cooling line problem? You have water in the hull? The water has to be going somewhere.

  8. #8
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by Horus View Post
    anyone have ideas on where i should look?
    Under the seat....

  9. #9
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    Quote Originally Posted by mrjetskey View Post
    did you change fuel lines, did you clean petcock out??and all fittings where fuel hose barbs are??>Marvin
    no i didnt change any lines.. if it revs nice on land i figured it was getting fuel

    Quote Originally Posted by o uncola o View Post
    Cooling line problem? You have water in the hull? The water has to be going somewhere.
    i didnt notice abnormal water in the hull.. and when i put the flush hose on i believe the water runs out of the back of it still.. meaning exhaust

  10. #10
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by Horus View Post
    no i didnt change any lines.. if it revs nice on land i figured it was getting fuel



    i didnt notice abnormal water in the hull.. and when i put the flush hose on i believe the water runs out of the back of it still.. meaning exhaust
    Sounds like you need to go thru the carbs again or have someone that knows what they are doing go thru them.

    And you need to change ALL fuel lines & install new fuel valve or you will be back to square one....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Kawasaki 1100 ZXI - bogs down after 10 mph
    By orlandois in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-01-2010, 11:46 PM
  2. 10 mph wot!!?
    By Oceanedge in forum Kawasaki PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-01-2010, 09:32 PM
  3. 1996 sl 900 10 mph @ wot
    By turbogn in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-05-2009, 05:33 PM
  4. e-bays 10 mph add factor
    By N8R in forum Yamaha Open Discussion
    Replies: 11
    Last Post: 11-21-2008, 03:25 PM
  5. + 10 mph with a ride plate and impeller
    By ZMANN in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 06-02-2008, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •