Results 1 to 6 of 6
  1. #1

    2000 virage NOSING DOWN PROBLEM

    Has anyone experienced their virage nosing down when they activate the acelerater instead of nosing up like normal?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    Welcome to the Hulk

    Have you had the jet pump apart?

    If so, make sure the pump wedge behind the stator is not installed upside down. The thickest part of the wedge must be positioned at the bottom.

    Jet Pump Maintenance and Service

    How to remove and re-install the Polaris 148mm jet pump (1994-2004)
    How to remove the 148mm modular jet pump (1994-2004)

  3. #3
    Eat my wash! Pro785Pilot's Avatar
    Join Date
    Jul 2010
    Location
    macomb mich
    Posts
    19
    Welcome to the Hulk! Do you have a trim button on your ski? try the "up" on the trim button and see if that helps.

  4. #4
    Never kick a terd on a Hot day! jorlando32's Avatar
    Join Date
    Jul 2009
    Location
    Durant, Ok
    Posts
    98
    I could be wrong but it sounds like you are trimmed all the way down. Try starting out with the trim up and then trim down as you accelerate. Of course your trim motor might be fried. Your ski has to be running to check if the trim motor is working.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    There is no trim on a Virage hull

    Just a 4 degree (stock) jet pump wedge.

  6. #6
    Never kick a terd on a Hot day! jorlando32's Avatar
    Join Date
    Jul 2009
    Location
    Durant, Ok
    Posts
    98
    Guess I was wrong.

    +1 on the wedge
    I bet thats never happend before!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 virage bogging down after new fuel hoses.
    By funfinn in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-21-2012, 05:21 PM
  2. 2000 virage 700cc engine problems!
    By sltx1050 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-30-2011, 07:21 AM
  3. 2000 virage bogs down @ 5-6k
    By timothyjl in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-06-2008, 08:54 PM
  4. 2000 Virage strange starting problem
    By bclake in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2007, 04:13 PM
  5. stalling problems on a 2000 virage
    By eddieb123 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-28-2007, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •