Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336

    recommend me a RRFPR

    so i've had some fueling issue's as of late, cost me some valves, and i'm not convinced the turbosmart reg. isn't part of my problem. so i was looking at this one

    http://www.summitracing.com/parts/AEI-13109/?rtype=10

    but was looking for some input from others.
    thanks
    mike


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,399
    +1
    2,524
    Mike, for an X model ski I would use this
    http://www.4-tecperformance.com/inde...oducts_id=1306

    It's a complete plug and play kit.

  3. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    yea i know thats the cats-meow but i already had the rude set-up so the return is already blocked off internally and hole drilled for the new return into the tank. thanks kinda why i was looking at just a reg. and what other people had been using

  4. #4
    Banned User
    Join Date
    Sep 2009
    Posts
    441
    OR....
    Get the BEGI unit, not as expensive and works great! I know a lot of guys running these with great success.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,399
    +1
    2,524
    Gotcha, that makes sense!

  6. #6
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    are you talking about that all in one begi unit? or the regular 2035 that everyone use's

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Can you elaborate on your problems bro?

  8. #8
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    basically burnt all the plugs out of the motor, burnt/cracked some valves. i watch my afr's like a hawk when testing and they're always good. 12.0's WOT. during my race i could only assume something fuel wise went poo-poo to cause all three cylinders to smoke the plugs. can't watch the gauge when racing.

    i battle back and forth could it be the pump or the reg. at idle sometimes it will take a few seconds to rise to 58psi, @ wot it will drop to 55psi. making me think its the pump. the pump is a new walbro though and if i pinch the return that bad boy will make over 104psi before i get scared and let go. leading me to believe its good.
    i didn't like the way the walbro slid into that grey gasket, felt loose. let me to believe some pressure was able to bleed off through. so i slid some clear hose over the outlet, trimmed it up with a razor so it was a VERY tight fit getting the pump with the grey gasket into the housing, hopefully creating a better seal. to bad the valve's were burnt and i didn't get a chance to test it.

    it just getting real frustrating i don't have anything fancy run GOOD gas 100, riva ecu, et137, 4"fizzle, reg. and rail and i just can't seem to keep this damn thing together

  9. #9
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Switch over to these if you can swing it bro before you replace your RRFPR. Lots of people including my best friend is running that unit without issues.. Richen it up a tad to. I dont even have a walbro pump at this point. WOT @ 55 sounds BAD! Do you have your boost line attached??

    http://cgi.ebay.com/ebaymotors/3-BOS...Q5fCarQ5fParts

  10. #10
    Banned User
    Join Date
    Sep 2009
    Posts
    441
    I know some that are using the 2025, I have the 2035, both work great depending on your application.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anybody can recommend me somebody to port my gp1200 65u !
    By mikey0124 in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 08-11-2016, 08:53 PM
  2. Mechanic in north jersey or ny Anyone able to recommend me someone?
    By carlosyiyo3011 in forum Shops, Tools and Tricks
    Replies: 2
    Last Post: 12-29-2013, 11:22 PM
  3. Can somebody walk me thru? RRFPR
    By tocullo in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-30-2011, 06:19 PM
  4. RRFPR-educate me PLEASE!
    By pet in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-11-2009, 12:32 AM
  5. recommend me a prop
    By jasonstang88 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-05-2009, 03:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •