Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    mongo's Avatar
    Join Date
    Jul 2007
    Location
    Stephensville, La
    Posts
    154

    Need help with my speed. Please!!

    I have a 03 conversion with a 3rude and riva ecu all the other bits as well. The best it does is 88 and change. I'm 280 and its hoy out but still i would think I should be in the 90's. I have a ff plate it came with 2 washers for each side in the front but I can only get 1 in each before the side wings are lower than the shoe. I have riva long and cut tabs and my sponsons are stepped. Nothing is hanging down below. Any advice is appreciated. Also it has a 158 prop and liner combo in it that i'm spinnin to 8500.

    Thanks Mongo


  2. #2
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by mongo View Post
    I have a 03 conversion with a 3rude and riva ecu all the other bits as well. The best it does is 88 and change. I'm 280 and its hoy out but still i would think I should be in the 90's. I have a ff plate it came with 2 washers for each side in the front but I can only get 1 in each before the side wings are lower than the shoe. I have riva long and cut tabs and my sponsons are stepped. Nothing is hanging down below. Any advice is appreciated. Also it has a 158 prop and liner combo in it that i'm spinnin to 8500.

    Thanks Mongo
    When at speed is it solid or does it bounce?
    what is your pump shoe set at?
    what is your ride plate angle?
    what are your trim tabs set at?
    what grate are you running?
    what pump yami skat i presume?
    have you got pump tunnel relief valves?
    what is your pump tunnel preasure?

  3. #3
    mongo's Avatar
    Join Date
    Jul 2007
    Location
    Stephensville, La
    Posts
    154
    At 88 its solid. I used a nickel to set the shoe. Ride plate is at .94. Long riva tabs with 3 washers on all 4 bolts. A stainless 800 grate. The pump is a 05 ho with the liner bored out to 158. The shoe has 2 holes drilled and the 2" extension has 2 jetworks valves. I've never checked pump pressure I also have another jetworks if I need it.

  4. #4
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Im not sure what the conversion guys are running but on the 2 strokes, the extended tabs scrubbed speed ! The handling setup is very important.

  5. #5
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    987
    +1
    47

    tabs

    Ditto on the RR tabs slowing it Down , they slowed Down my old two stroke 2 mph On glass water . they were designed for rough water racing keeping the front end down .

  6. #6
    mongo's Avatar
    Join Date
    Jul 2007
    Location
    Stephensville, La
    Posts
    154
    With the short tabs on I have to shim the back of the ride plate down and lost a mile an hour.

  7. #7
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    shim the tabs down 60-100 thou... Plate seems to be happier around .760-.850 on my gprxp.. anything over 1.000 and it over stuffs, .960 its a lil unsettling... .850 and .100 on tabs its rock solid @ 85-86 with an x charger and ecu...

  8. #8
    mongo's Avatar
    Join Date
    Jul 2007
    Location
    Stephensville, La
    Posts
    154
    Thanks Ink I'll give that a shot tomorrow.

  9. #9
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    Just to clarify I was talking about shimming the stock tabs not the extended tabs.. Start @ .100 and lossen the hull up from there..

  10. #10
    mongo's Avatar
    Join Date
    Jul 2007
    Location
    Stephensville, La
    Posts
    154
    OK I'll use the cut RIVA'S.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with my wave blaster 2 dies under load please help me
    By Waveblaster2012 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-04-2012, 10:11 AM
  2. Need help with my 760 PLEASE!!!
    By Tatback in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 10-30-2011, 12:07 PM
  3. Needs help with my issue please
    By fitnessguy in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-18-2011, 03:32 AM
  4. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •