Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 59
  1. #1

    Angry 2003 seadoo 4 tec supercharger slips when accelarating hard and hits the rev limit

    Hey guys, i have a 2003 gtx sc seadoo that hits the rev limit when craming the throttle wide open and slips unless you feather the throttle and it gets up and goes between 55-60 mph at around 7200-7800 rpm.I have replaced the the impeller with a sbt reconditioned one,brand new oem jet pump,new brgs. and seals in jet pump and carbon seal, boot and stainless steel piece in front of the carbon seal with new o-rings.Jet pump came with new wear ring and impeller and wear ring still looks good, no water coming in around boot or carbon seal.Shop manual says up to 40 thousand clearance between impeller and wear ring and all checks out The impeller is the right one.The nozzle looks great, no broken veins or damage.Could the supergharger be slipping or something else? Please any ideas would be helpful. Thanks, Motormadness !


  2. #2
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by motormadness View Post
    Hey guys, i have a 2003 gtx sc seadoo that hits the rev limit when craming the throttle wide open and slips unless you feather the throttle and it gets up and goes between 55-60 mph at around 7200-7800 rpm.I have replaced the the impeller with a sbt reconditioned one,brand new oem jet pump,new brgs. and seals in jet pump and carbon seal, boot and stainless steel piece in front of the carbon seal with new o-rings.Jet pump came with new wear ring and impeller and wear ring still looks good, no water coming in around boot or carbon seal.Shop manual says up to 40 thousand clearance between impeller and wear ring and all checks out The impeller is the right one.The nozzle looks great, no broken veins or damage.Could the supergharger be slipping or something else? Please any ideas would be helpful. Thanks, Motormadness !
    Something doesnt sound right, doesnt sound like a charger slipping if it is banging the limiter. What RPMs are you seeing at the "limiter" when you stab the throttle? Got a hunch it may be in the sparkplugs.......Sounds like you have covered all the basics on the pump, not sure about the SBT impeller, hopefully it's pitched properly for that ski. Almost sounds like your loosing fuel or low fire or weak coil maybe. Need a better description of "hits the rev limiter".

  3. #3
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    I would try a different impeller. sounds like sbt pitched it for a non sc model.
    Dont know where you are, but maybe someone has an impeller local you could try out.

  4. #4
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Another thought, when you got the new pump from SBT did you get the large O-ring that fits between the pump shoe and pump, did you install one. Sounds like a stupid question but you never know. Why did you replace the entire pump, I think thats what I got from your post?

  5. #5
    dnielsen, hey man this is motormadness. I have put in twoo new oem wear rings and the pump would just wipe the ring as soon as you start it up in the 3 oclock and 9 oclock area. So i took the pump back out and checked the i.d. with a set of mics and it showed it was egged. And when you would torque it up to the back it would squeeze it more and cause it to egg even more.So i replaced the pump with oem and oem wear ring and a sbt recondition impeller. It stopped the sudden wiping of the ring but still cavitates or slipps when you take off suddenly and cram the throttle.The rpms are around 7200-7600 when you cram the throttle and its slipping.I checked the #on the impeller and it is for a 03 gtx s.c. .Everything still looks good in the pump and all new parts around the carbon seal last nite.I still feel like it is cavitating on take off because of the slippage and it hitting high on the rev limit and it does good after 10 mph and up.Also at higher speeds it feels like the rpms are much higher than the speed around 55-60 [email protected] rpm.The pump veins and pump look good,the ring shows a sign where the impeller has setted a little but still within the allowable tolerance.Any advice would be great from anybody. I thought maybe electrical but runs good on top end !Thanks to anyone and everyone that has replied! Motormadness

  6. #6
    hey forgot to mention that i used the same rubber seal around the jet pump housing. Where it mates up to the shoe. The seal look good ! Motormadness

  7. #7
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Check the hose between the supercharger and throttlebody, make sure the clamps are tight and the hose is in correct position. Also check the hose for splits or air leaks. 60 mph At 7600 Wot seems low, if you were at 8000-8200 top speed would be 64-65ish. If the hose is loose when you nail it it could be blowing off. Also check the slip on the charger. When these things cavitate on take off its usually when you nail it hard, the engine bounces off the limiter once, twice, sometimes three times before the impeller gets a bite. Once the impeller bites it pulls like hell to WOT and top speed. Your discription seems to indicates two scenerios, cavitation or loss of boost at pegged throttle. Check the hose real good....

  8. #8
    Thanks for your reply. I will check that tomorrow. Let me make sure what you said and that was check the hose going to the s.c. to see if it is tight and has no cracks and etc. I double check the clearance between the impeller and wear ring tonite and its about 12 thousands of a inch clearance around. The impeller looked good.So to rule out the rubber seal around the pump on the mating surface to shoe, i siliconed it all and the intake grate and put in the water and it done the same thing.what you was talking about hitting the rev limiter 2or3 times before it jumps up and takes off sounds like this ski.Thanks for all your help man!

  9. #9
    You said check the slip on the supercharger, mind if i ask what that is ?Not dealt alot with these s.c. Thanks !

  10. #10
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by motormadness View Post
    You said check the slip on the supercharger, mind if i ask what that is ?Not dealt alot with these s.c. Thanks !
    Might be a good idea for you to do a search on supercharger slip so you'll have a little understanding of what and why your checking. It's not all that complicated to do but you'll need some tools if you don't already have them. Your gonna need a torque wrench, a few specialty tools for holding the gear on the charger if you decide to pull the charger to check. You can do it in place if you get a cam lockng tool to keep the motor from spinning while you check it, most decide to pull it to check instead. If you can get your hands on a shop manual it'll tell ya exactly how to do it. After checking if it's bad send it to Jerry, he has great service and will have it done and shipped back usually the same day he gets it.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 07-20-2015, 06:53 PM
  2. 2003 Seadoo 4 tec Supercharge burning oil
    By Seadoo 03 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-03-2015, 02:58 PM
  3. 2003 Seadoo GTX 185 Supercharge question... Please help
    By Rookiepwc in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-10-2013, 12:43 PM
  4. 2003 gtx 4-tec supercharged do i have a problem?
    By skihead in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2013, 10:41 AM
  5. 2003 Seadoo 4-Tec GTX for sale...
    By brittrich in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-12-2012, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •