Results 1 to 9 of 9
  1. #1

    Unhappy 1998 Polaris slth bogging down need help!

    I am a newbie when it comes to pwc. I just bought a 1998 Polaris slth and figured that if it started up I was good. Needles to say when I put it in the water I found out that I was wrong. After I started it, the ski only went like 7-8 mph at full throttle. It bogged down the whole time I was in the water. The motor turned off several times while I was in the water. Every once in a while it wanted to take off for like 2 seconds and then it would be in a bogged mode. I did a visual of the carbs and they looked very clean. I checked the carb filter and it was clean too. I did notice some sand in the fuel lines. I donít think that should be there. I canít figure it out! I changed the spark plugs. I made sure it has plenty of oil and gas. Can someone suggest what might be wrong with it and what I should check or do to get it back to par. Thank you for your help.

  2. #2
    lxman88's Avatar
    Join Date
    Aug 2010
    will the ski get up to a good speed if you choke it? if so most likely running lean. also what kina comprssion numbers are you getting with it. and no there should no be anything in your gas lines but fuel if i was you i would take the tank out clean it and flush the compleate fuel system and take the carbs apart and blow the lines out maybe need to replace the lines if the are old and brittel that can equal bad news for a pwc clean all the jets out in the carbs and try it agin a ski will most the time run good out of the water its when you put the impeller in the water when it will act up

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Welcome to the Hulk

    Click the signature links below, should get you going in the right direction.

    Sounds like you need to remove the carbs and completely clean/rebuild them internally, AND replace all the fuel lines and check/clean the rest of the fuel system. The fuel system from inside the fuel tank to carbs should be 100% clean; no water, dirt, sand or other stuff. Just clean liens and clean fuel.

  4. #4
    What would be the procedure to clean the crabs? Can I use any crab cleaner?
    Thank you.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Quote Originally Posted by jb30 View Post
    What would be the procedure to clean the crabs? Can I use any crab cleaner?...
    Carbs, not crabs

    Did you click my signature links? The info is linked through there, and also posted in multiple threads on the forum.

    Any normal carburetor cleaner product/spray should work. The key is that you must actually dis-assemble each carb, clean all the internal passages and small parts, then put it back together with new parts from a genuine Mikuni rebuild kit.

  6. #6
    Canadian Beaver Inspector jkindt's Avatar
    Join Date
    Sep 2009
    Lethbridge, AB, Canada
    Quote Originally Posted by K447 View Post
    Carbs, not crabs
    Well....hopefully the ski doesn't have crabs!!!

  7. #7
    Does anyone know a good mechanic that works on Polaris Jet Skiís in Orange County, CA. I need to get my CARBS rebuilt! J Thanks for any help!

  8. #8
    I just ran a compression test and I get 120 on both cylinders.

  9. #9

    Join Date
    Oct 2010
    Auckland, New Zealand
    Hey MAte, i had the same problem when i brought my X45, i cleaned the carbs, replaced spark plugs and syphoned the fuel out, and put new stuff in, one of them done the trick, now i only have a problem with it kind of misfiring at full tit!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Polaris SLTH 700 no spark
    By in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-27-2008, 10:11 AM
  2. 1998 Slth 700 Question ?
    By troyzstang in forum Polaris Open Discussion
    Replies: 8
    Last Post: 10-24-2007, 07:14 PM
  3. HELP - Polaris SLTH stalling out
    By acizzle in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-01-2007, 07:43 PM
  4. Polaris SLTH Problem!
    By smoke20 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 07-19-2007, 01:30 PM
  5. 1998 Polaris 700 SLTH Electrical
    By kawhead in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-29-2007, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts