Results 1 to 3 of 3

Thread: 94 slt pump

  1. #1
    retro's Avatar
    Join Date
    Jun 2009
    Location
    Annapolis
    Posts
    492
    +1
    2

    Question 94 slt pump

    I started pulling the pump on a 95slt and the problem I'm having is there are two areas on the wear ring where it looks like sand got in between the wear ring and housing and pushed the ring in. To make a long story short the impeller won't come through the ring because there is not enough clearance. I've pried and wiggled this thing to death with no luck. Any suggestions.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Sounds like corrosion between the liner and the aluminum casing, in which case the wear ring is now junk and you need a new one

    Use the impeller tool to unscrew the impeller from the sub shaft. Then you may be able to wiggle the impeller out of the back of the wear ring.

    If that doesn't work, then saw a slot through the wear ring, and pry it open enough to allow the impeller to slide out.

    I expect the impeller will need refurbishing, which is not expensive. SBT and Impros are two places that can do it.

  3. #3
    retro's Avatar
    Join Date
    Jun 2009
    Location
    Annapolis
    Posts
    492
    +1
    2
    I was able to get the impeller out of the wear ring by cutting 3 slots through the ring. There were 3 areas that were blistered. Thanks for the suggestions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SLT 750 - bilge pump?
    By gonu50 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-12-2015, 11:41 PM
  2. 94 SLT 750 Oil Pump / Oiling Question - Converting to variable ratio pump
    By ThrottleOut in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-13-2013, 10:28 AM
  3. 94 slt 750 fuel question
    By ace16a in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-08-2007, 11:10 PM
  4. 94 slt 750 problems
    By ace16a in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-28-2007, 03:45 PM
  5. '94 SLT 750...deal or no?
    By Fish Man in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-22-2007, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •