Results 1 to 7 of 7
  1. #1

    after modification repairs - fine tuning

    I finally got my 97 sltx1050 in the water however, there needs to be some fine tuning.

    Here is what i experience:
    on a full charged battery, it starts nicely and the rpms idle aaround 3500 to 4500. Does this seem pretty high? Then, in the water, it drops down to around 1500rpms.

    Now, after a few minutes warm up, as i accel slowly, theres bogging and it seems like its about to die but, when it like its about to die, i gun it and it flies. i cant get my pwc to just go slow. it needs to be opened up then let go to slow down. This is the main problem.

    Other starting problems occur later in the day after a few long runs. I'm afraid to turn of the ski sometimes because i feel it may not start back up and when it doesn't, i usually have to remove the air filter cover and spray some engine starter into the carbs because remember, i cant just squeeze the accelerator a bit cause it make the engine bog. therefore upon starting, i have to rely on the engine starter spray to start the engine...ALWAYS cause i cant just use the accelerator. And when its about to die, i just keep spraying the engine starter spray.

    If you have looked at my past threads, i asked about a particular system which was identified as the oil misting thing. are we sure we dont need this?

    I replaced my MFD with a same type with the same connector except it has a trim indicator which my pwc does not have. does my electrical system recognize foreign/different mfds? Does the correct mfd have to match the brain/elec box?

    My MFD displays a low fuel even though i fill my tank up more than halfway when i go out riding. Does the error reading send signals out to control the fuel which may cause this bogging?

    When im cleaning my pwc and have the flushing device connected and water running, the rpm rise and when i rev it, it revs high and doesnt come down. I usually have to use my hand to cover the carbs from getting air to bring it down. i try to turn off the ski by pressing the red button but doesnt work, so i pull the spark plug wires off but the damn motor wouldn shut off. WEIRD!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    No problem using a different MFD version. No compatibility issues should arise.

    Low Fuel indication means the fuel float in the tank sender is probably no longer floating. Replacement floats can be purchased from John Zigler.

    I am no carb expert, but it sounds like your carburetors are set up to be much too lean in the Lows. That is why you are seeing the 'death rev' when you apply throttle out of the water, and why the engine will continue to run without spark. When it continues to rev high like that after pressing STOP, apply full throttle and it will stop running. Or apply the choke, if you have one.

    Have you cleaned and rebuilt the carburetors?
    What settings are the adjustment screws?

  3. #3
    the carbs were cleaned and adjusted to factory settings by a certified technician.

  4. #4
    the carbs were cleaned and adjusted to factory settings by a certified tech.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by kainalo808 View Post
    the carbs were cleaned and adjusted to factory settings by a certified technician.
    Still worth checking the carb screw settings. Not hard to do, just a little tedious.

    Do you know the correct settings?
    Do you know how to check them?

  6. #6
    Please advise.

  7. #7
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400
    idle needs to be 1250 in the water,set that first.replace the fuel float

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200r First Run after Modifications [Help Plz]
    By Coveted in forum Yamaha PWC Performance (2-stroke)
    Replies: 74
    Last Post: 08-21-2016, 07:02 PM
  2. 01xpl 1020 bigbore fine tuning and questions
    By abarrassr07 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 04-04-2012, 10:38 AM
  3. first ride after modifications
    By gorilla03 in forum Polaris Open Discussion
    Replies: 58
    Last Post: 07-26-2007, 11:32 PM
  4. a few results after modifications
    By watermedic in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-26-2006, 07:50 AM
  5. finally went to the lake after hull repair
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 04-13-2006, 11:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •