Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

    Damaged broken 4-Tec ECU's

    Anyone have any nonworking ECU's Stock Riva RR etc.


  2. #2
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    i have one that came out off a 04 rxp. [email protected] you can send whatever you like.

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by rxp127 View Post
    i have one that came out off a 04 rxp. [email protected] you can send whatever you like.
    $$$ sent

  4. #4
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by beerdart View Post
    $$$ sent
    i made a mistake on the email. i forgot the i in mail. sorry about that.

    [email protected]

  5. #5
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    got it now thanks. i will ship it out sometime before 5.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

  7. #7
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    I have one out of an 05

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You testing candoo?

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by Insanediego Joe View Post
    I have one out of an 05
    Is it cooked?

  10. #10
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    oops, sorry bro it works just fine.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 gtx 4 tec ecu or injector problem
    By BocaBoyz in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-28-2014, 05:20 PM
  2. FS Riva Racing 2004 4-tec ECU-SOLD
    By 8 is enough in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 03-25-2012, 04:58 PM
  3. FS 2 Damaged 06 4 Tec block's
    By suck my wake in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 03-18-2010, 05:52 PM
  4. WTB Damaged/Used 4-Tec Stainless Wear ring
    By mrbtd in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 11-24-2009, 10:33 PM
  5. Looking for 2003 GTX 4 tec ecu, Non Supercharger
    By blackrxp in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-30-2009, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •