Results 1 to 6 of 6
  1. #1
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258

    06 RXT Runs very wet and steers itself

    After sucking up debris. I think it was a piece of wood. The wear ring got a groove in it. So I changed out the wear ring and the speedo reads in the upper 40's and I can feel Im going much faster than that. And the bow is very far in the water. The impeller looked fine and the ski has lots of power and is running right at 8100.

    The problem is the bow being in the water is scrubbing lots of speed and its borderline scary that it steers itself


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by GGG View Post
    After sucking up debris. I think it was a piece of wood. The wear ring got a groove in it. So I changed out the wear ring and the speedo reads in the upper 40's and I can feel Im going much faster than that. And the bow is very far in the water. The impeller looked fine and the ski has lots of power and is running right at 8100.

    The problem is the bow being in the water is scrubbing lots of speed and its borderline scary that it steers itself
    Sounds like maybe the opas paddles are not rising due to sucking debree and clogging the line or the line was not reinstalled. Also inspect your intake grate to make sure it is not damaged or hanging low, pump shoe for damage in the tunnel, and nozzle to make sure everything is tight back there.

  3. #3
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    the OPAS moves up and down by hand. Ill have to spray the hose in there. I double checked everything to do with the pump. There is an identical ski right next to it on the same trailer and i could not find a single difference between the 2 of them.

    Thank you for your quick reply

  4. #4
    Quote Originally Posted by GGG View Post
    After sucking up debris. I think it was a piece of wood. The wear ring got a groove in it. So I changed out the wear ring and the speedo reads in the upper 40's and I can feel Im going much faster than that. And the bow is very far in the water. The impeller looked fine and the ski has lots of power and is running right at 8100.

    The problem is the bow being in the water is scrubbing lots of speed and its borderline scary that it steers itself
    I had a similar experience with a RXT and it was a cracked intake grate bar, it was scary at 50mph and above.

  5. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Quote Originally Posted by RXP6 View Post
    I had a similar experience with a RXT and it was a cracked intake grate bar, it was scary at 50mph and above.
    so the bar was just cracked? not bent to one side or missing a bar?

  6. #6
    Quote Originally Posted by GGG View Post
    so the bar was just cracked? not bent to one side or missing a bar?
    Is was broken on one side but it looked fine when visualy inspecting it, and I guess from the water pressure it was vibrating at speed and causing weird handling.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 2007 RXT STOCK Exit Nozzle and Steering Nozzle
    By gbayus in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-26-2015, 05:00 PM
  2. '06 RXT scored oil pumps and pieces.
    By rattlsnak in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-31-2014, 11:41 PM
  3. Replies: 11
    Last Post: 07-19-2011, 05:41 PM
  4. Jerry and 06 RXT Supercharger Rebuilds???
    By Ackins in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-24-2010, 08:48 PM
  5. First day and my new RXT runs like POOP!
    By 2006 RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-09-2007, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •