Results 1 to 9 of 9
  1. #1
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8

    New Solas cuting up new plastic wear ring

    Just fitted new 15/22r Solas and new plastic wear ring into my RXTX. After fitting I left it about 2 hours and then started it to find bits of plastic wear ring blowing out the back. I did the wear ring in the freezer trick so it may have expanded a bit since fitting the prop which went in ok at the time. Anyone else had this happen?? its seems to have cut its own groove now but wondering if its normal. Cheers


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by fussy1 View Post
    Just fitted new 15/22 Solas and new plastic wear ring into my RXTX. After fitting I left it about 2 hours and then started it to find bits of plastic wear ring blowing out the back. I did the wear ring in the freezer trick so it may have expanded a bit since fitting the prop which went in ok at the time. Anyone else had this happen?? its seems to have cut its own groove now but wondering if its normal. Cheers
    Normal bro. When you fit a new wear ring always crank the ski in the water the first time around.

  3. #3
    First off make sure you got the right wear ring.
    Second start in water.

  4. #4
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Ok Cheers for that, looks ok after running on the hose just now,(I hope) I need to get up to speed with Seadoo tricks again its been to long, to much time working on the Ultra.

  5. #5

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    I've been seeing more and more solas impellers not true.....the threaded shaft they attach to as they clean up the edge must be off or the pump shaft I have in three pumps is off????

  6. #6

    Join Date
    Jan 2009
    Location
    Scotland, UK
    Posts
    290
    +1
    9
    Quote Originally Posted by fussy1 View Post
    Just fitted new 15/22r Solas and new plastic wear ring into my RXTX. After fitting I left it about 2 hours and then started it to find bits of plastic wear ring blowing out the back. I did the wear ring in the freezer trick so it may have expanded a bit since fitting the prop which went in ok at the time. Anyone else had this happen?? its seems to have cut its own groove now but wondering if its normal. Cheers
    Mine did exactly the same as you mentioned when i fitted the same prop. I initially thought the pump bearing was bad but it wasn`t. Have now changed to the stainless wear ring, so there will be no more issues with the prop grinding on the ring.

  7. #7
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Well went for a spin today with my son on the back, The ski is a 08 RXTX 255, mods so far, R&D intake grate, R&D air intake mod, Solas 15/22 r, reverse bucket mod, new wear ring.
    Showed 8060 rpm with two up and half a tank of gas, do you guys think thats ok for whats been done so far?? will have to get the GPS on it.

  8. #8
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by fussy1 View Post
    Well went for a spin today with my son on the back, The ski is a 08 RXTX 255, mods so far, R&D intake grate, R&D air intake mod, Solas 15/22 r, reverse bucket mod, new wear ring.
    Showed 8060 rpm with two up and half a tank of gas, do you guys think thats ok for whats been done so far?? will have to get the GPS on it.
    Depends on weather I suppose. Mine @ 90 degrees and 80 water temp turned a 15/22 @ 8040. Will turn 8100 in the cooler months. At that RPM's with that prop you are high 72's to low 73 assuming everything is right on the bottom of the ski.

  9. #9
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Thanks for that. These respond good to small mods my ultra 250 was hard to get mph out of.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seating new plastic wear ring
    By juan valdez in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-26-2012, 10:09 PM
  2. FS FS: Solas 14/19R 1 summer use and BRAND NEW SS Wear Ring
    By RXP_Noah in forum Sea Doo Classifieds
    Replies: 18
    Last Post: 08-24-2011, 09:41 PM
  3. New (thicker) wear ring
    By SconnyRider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 09-08-2007, 05:29 PM
  4. anyone install new black wear rings yet?
    By Pale Rider in forum 4-Tec Performance
    Replies: 31
    Last Post: 08-11-2007, 12:53 AM
  5. New impeller rubbing on new ss wear ring...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-16-2007, 02:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •