Results 1 to 7 of 7
  1. #1

    STX-12R cranks very slowly

    Dear all,

    I have a weird problem with my STX-12R.
    Two weeks ago, I tested compression, and everything
    was fine (3x 10bar). Went out for a quick ride as usual
    and no problems. Everything fine, everything good.

    Yesterday (i.e., 2 weeks later), I tried to start the engine. Problem: engine/starter does
    not really turn over, but very slowly. It is like 1 rpm, like something blocks the
    engine/starter from turning over properly. Checked the intake/pump for any
    objects blocking, but looks good. There is no oil or anything in the hull.
    Battery is freshly charged.

    Any advice on what to check?

    Desperately,
    Erik


  2. #2
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    Can you turn it by hand (remove the spark plugs). If it turns freely maybe it's just some corrosion on the battery terminal? Take the leads off and give them a clean?

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266
    check the pump..bearing might have failed..had one in a couple of weeks ago..guy thought he blew up the engine..turned out it was just the pump bearings.

  4. #4
    Good news: it's not the engine.

    Bad news: the impeller somehow touches the housing.





    Do I need to replace the impeller housing (is this the correct term?) or can
    a workshop grind this?

    Do I need to replace the impeller or can it be saved by grinding, too?

    Two stupid questions:
    How come that this happens?

    Why is this dog-sh*t-like color on the impeller?

    Regards,
    Erik

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266

    not terribly tragic

    cept you're in France..that will make it a bit more expensive.

    prop can be refurbished

    bearings are not difficult to replace

    tough part will be getting the impeller off the shaft

    you'll need a prop tool, bearing and seals and a prop refinish

    the housing if not badly scored can be used..a new one makes this work very expensive.

  6. #6
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    You can buy an impeller tool and remove it yourself. You may be able to take your pump to an engine shop and ask them to resleeve it.

    The brown colour looks to be rust (or the grease from the bearings, not sure). The impeller doesn't look too bad. This is pretty common, basically salt water gets between the pump case and the lining and causes the lining to bulge out so it touches the impeller. That wears the impeller and lining and exposes it all so it rusts.

  7. #7
    Ok, thanks guys!
    I will try to remove the impeller and bring the housing to an engine shop.

    If you say "re-sleeve", does this imply that the scratched surface I can
    see in the housing is a sleeve like sleeves in a car engine, i.e., removable?

    Will keep you updated!



    Thanks again,
    Erik
    P.S.: @nmpeter: as a German working/living in France, I am aware of the
    ridiculous prices and value for money you get here. The difficult problem,
    however, will not be the insulting amount of money I will have to pay, but
    first of all to find an engine shop that *wants* to do this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 Kawasaki STX-15F Crank Removal
    By sraab928 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 08-01-2012, 05:57 AM
  2. 1999 XP Limited 951 turns over very slowly, ideas
    By AstroSeadoo in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-19-2010, 06:01 PM
  3. 09 STX-15F Cranking Problem
    By 70455gto in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-13-2009, 04:41 PM
  4. FS: Brand New OEM Ultra 150/STX-R crank
    By SAVAGEXP in forum Kawasaki Classifieds
    Replies: 3
    Last Post: 09-13-2008, 11:40 PM
  5. Replies: 7
    Last Post: 06-16-2008, 04:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •