Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1

    Wet Wolf Ajust-a-thrust

    Has anyone installed a Wet Wolf AAT on a 94-95 SL750. At this point I will try just about anything to get out of the hole quicker. I am a bigger guy and the 750 has good thrust, but even with trim down is sluggish out of the hole. Not blubbery or lean.

    Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,277
    What exactly is happening when you accelerate hard from low speed?

    Does the engine RPM jump up right away, but the impeller doesn't 'bite' right away?
    Does it feel like the impeller is 'slipping' or spinning without much thrust?

    As the hull begins to pick up a little forward speed, does the thrust from the jet pump improve noticeably?

    Do you have any water leaks around the drive shaft at the through-hull bearing?

  3. #3
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    It gives all indication that its running strong, just feels like Im pulling a trailer.

    So if you are going about 3-5 MPH, peg the throttle and the nose comes up,,


    insert: does not studder or blubber
    does not jump out of the water and then fall on its face

    , hunts for power then planes off and goes really strong to about 6050 RPM and 52.0 on D-O-M (48 GPS)

    No spline damage
    No drive shaft slip
    good clearances
    no leaks
    good seal on pump shoe and ride plate

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Lots of people have installed the AAT on a 750.

    It does sound like you're having a performance problem though.

    My old 650/750 conversion used to leap out of the water.

    What impeller is installed in it?

    How are the vanes on the stator?

    6050 RPM is a bit low for that ski. (6300 is normal) What's your elevation?

    How does your piston wash look?

    What's your compression?

  5. #5
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    I will check, dont know on stator and impellor

    wash looks great
    compression is 135-140 on all three

  6. #6
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Elevation in Raleigh is about 100Ft above SL

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Elevation isn't an issue.

    Compression is great.

    Wash looks great? and only getting 6020 RPM???? (something's not right....)


    Take a look at the impeller and pump.

    Have you inspected the reeds ever? (alot of mist coming out the carb tops when idling?)

  8. #8
    Canadian Beaver Inspector jkindt's Avatar
    Join Date
    Sep 2009
    Location
    Lethbridge, AB, Canada
    Posts
    1,721
    Sounds just like my wife's SL650.....can't get it past 6040 rpm. I would have a look at the impeller as well. Does it get higher than that rpm when you are punching it off the line, or when you are pulling out of a donut?

  9. #9
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    reeds were replaced last year, no mist.



    pump is only thing that has not been rebuilt

  10. #10
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    j

    i have seen 6400 when jumping

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts ZXi STX Wet Wolf Adjust A Thrust
    By jdakrt in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 10-21-2013, 08:09 AM
  2. WTB wtb 140mm pump wedge 96 xp and a wet wolf adjust a thrust
    By middaughm in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 02-21-2012, 02:54 PM
  3. Wet Wolf Adjust-A-Thrust
    By jcorallo in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 05-28-2009, 06:29 PM
  4. Wet Wolf Adjust a Thrust
    By BAYOU FZR in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-21-2009, 10:29 AM
  5. Adjust-A-Thrust cones from wet wolf on any RXP's?
    By watermedic in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-23-2005, 09:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •