Results 1 to 3 of 3
  1. #1

    Post rxp turbo problem

    just had a replacement turbo fitted to my rxp. all pipes and lines are on correctly but upon runnig after 5 mins found water in my oil dipstick. have flushed out water from engine, 18 litres later that is. then removed 2 inch pipe from top of turbo and 4 inch pipe then started ski. water poured out of the top of turbo. how else could water be getting into my oil . could it be a faulty turbo? its a new engine with about 8 hours. any help any one please


  2. #2
    Norwegian Wiking Trond's Avatar
    Join Date
    Nov 2007
    Norway, Kristiansand
    Did you mix oil-lines and cooling lines?? Pics and more details please??

  3. #3
    if your turbo is water cooled that could be the case or your waterjacketed pipes are leaking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turbo boost problem
    By miamirider in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-14-2008, 07:29 PM
  2. turbo rxp
    By Avion3333 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-04-2008, 10:38 PM
  3. Turbo Rxp Australia (1tuff Rxp)
    By US PERFORMANCE in forum 4-Tec Performance
    Replies: 10
    Last Post: 01-23-2008, 11:57 PM
  4. MSX 150 Turbo Problem
    By mhucul in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-18-2007, 03:44 PM
  5. My new RXP Turbo
    By Big Red Monster in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-15-2006, 11:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts