Results 1 to 10 of 10
  1. #1
    chuckbatts's Avatar
    Join Date
    Jul 2010
    Location
    Austin, Texas
    Posts
    166

    R&D ride plate installation question....please help?

    I just installed the R&D ride plate.....However, everybody recommended using the stock shims in the back. There weren't any shims there. I just had the big ride plate and then the silver bracket and then the 4 bolts. Does anybody know about these stock shims??? I went ahead and used 1 washer on each side in the back and put nothing in the front (as recommended by instructions). Any ideas? I haven't made it to the lake yet.


    Thanks,
    Chuck


  2. #2

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    that is exactly what i did. mine handles great... the speedo doesnt work very well due to the pick up being re positioned....

  3. #3
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    The silver "bracket" is the stock shim.
    The R&D plate didn't come with washers/shims?

    Nevermind....I see you had the R&D washers.

  4. #4
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    double post

  5. #5
    chuckbatts's Avatar
    Join Date
    Jul 2010
    Location
    Austin, Texas
    Posts
    166
    Thanks guys! You are awesome. I used the stock silver plates and then put one washer on each side in the back. Yesterday with stock ride plate and sitting up (not superman) the best I did was 67.1 and today the best was 69.5mph (gps)....however, the water was smooth as glass and I felt like I was riding a bull. I will have to add another washer in the back on each side now and lose some mph to quit the bouncing. Stock except for the R&D grate and pump seal kit and R&D ride plate. I hope to still hit 68.5-69mph after adding a shim....we will see.

  6. #6
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Good numbers. What intake grate are you running ? Be careful if you are still using the stock one.

    Quote Originally Posted by chuckbatts View Post
    Thanks guys! You are awesome. I used the stock silver plates and then put one washer on each side in the back. Yesterday with stock ride plate and sitting up (not superman) the best I did was 67.1 and today the best was 69.5mph (gps)....however, the water was smooth as glass and I felt like I was riding a bull. I will have to add another washer in the back on each side now and lose some mph to quit the bouncing. Stock except for the R&D grate and pump seal kit and R&D ride plate. I hope to still hit 68.5-69mph after adding a shim....we will see.

  7. #7
    chuckbatts's Avatar
    Join Date
    Jul 2010
    Location
    Austin, Texas
    Posts
    166
    R&D intake grate but with using either no shims in back (other than stock shims/silver bracket) or 1 shim in back or 2 shims in the back....all options resulted in horrible bouncing......approx.2.5 mph gain in all cases but the ski bounces way too much. Any ideas? I was on glass-smooth water for all 3 scenarios. The ride plate gave awesome gains, but not fun to ride.

  8. #8
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    have you verified that your trim is working properly and accurate?? are you making these runs on neutral trim??

  9. #9
    chuckbatts's Avatar
    Join Date
    Jul 2010
    Location
    Austin, Texas
    Posts
    166
    I tried at neutral as well as one up and one down. The trim is working. I can't figure it out

  10. #10
    bkweld's Avatar
    Join Date
    Jul 2010
    Location
    St John's River,N FL.
    Posts
    147
    porpoised a lot at stage 1 on rd plate but as i added more power the less it bounced.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Couple of questions on R & D nozzle, ride plate install
    By powerstroke250r in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 04-27-2016, 11:11 PM
  2. 15f R&D Ride Plate and Intake questions....please help!!!!
    By jimmygoal in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-25-2010, 05:13 PM
  3. R&D ride plate install question
    By superair in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 03-20-2009, 02:15 AM
  4. Ride plate install Worcester MA area
    By bruinsrme in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-13-2008, 10:00 AM
  5. D plate install question
    By skysurfer2010 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-20-2007, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •