Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Cam results???

  1. #1
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311

    Cam results???

    I like what was posted about the cam gears but I have not seen any post about how the avalible cams perform are they worth it anyone tried them


  2. #2
    Professional Alike Racer Clazz. Teerayoot's Avatar
    Join Date
    Jun 2010
    Location
    Koa LumPoo!,Thailand
    Posts
    168
    Improvement noticeable on mine,as advertised ,+ top speed gain 2mph.

    i using s2 setting ,not try others setting yet.

    Mr. Hitman have try experiment many setting,i think he discuss a lot about Cam Gear already.


    Worth 199$ ,even you using just one (s2),Cam Gear come in two ,each for Intake and Exhaust


    I might try to sell Exhaust side for you use on Intake Side a half price

  3. #3
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    No one using aftermarket cams???

  4. #4
    tobbe tobbe sweden's Avatar
    Join Date
    Jul 2008
    Location
    Vagnhärad sweden
    Posts
    270
    I whonder if someone try the s3 setup

  5. #5

    Join Date
    Apr 2010
    Location
    Vladivostok, Russia
    Posts
    65
    +1
    1
    I am. Riva racing cams. Way too much power (along with full stage 3+ upgrades) for stock pump with 13/25 impeller, cavitation is really-really bad. More then without cams, obviously. Did not measure top speed, cant say anything about that (before cams top speed was 84 mph). Removed stock pump and went with 160mm 12 vane Skat pump (13/23 impeller) and, weird, but even with 109 VP fuel still not enough power to go faster then 74 mph with less then impressive acceleration. Zero cavitation, however.

  6. #6
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    I love how they call them "racing cams" when all they are, are NA cams.

  7. #7
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    Quote Originally Posted by Denis View Post
    I am. Riva racing cams. Way too much power (along with full stage 3+ upgrades) for stock pump with 13/25 impeller, cavitation is really-really bad. More then without cams, obviously. Did not measure top speed, cant say anything about that (before cams top speed was 84 mph). Removed stock pump and went with 160mm 12 vane Skat pump (13/23 impeller) and, weird, but even with 109 VP fuel still not enough power to go faster then 74 mph with less then impressive acceleration. Zero cavitation, however.
    Your pitch with the 12 vane is wrong in my opinion. I started with that pitch and worked my way to 12/20 to get my RPM's up. I estimate your RPM's to be at 7800. Also the tail cone on the skat modified pump is very long. Remove some of the shims and you will get some more RPM's. I have 1 shim in. I think I am going to remove the last shim/spacer on the tail cone.

  8. #8

    Join Date
    Apr 2010
    Location
    Vladivostok, Russia
    Posts
    65
    +1
    1
    thank you, Carlos! You guessed rpms right, about 7800 is max that I saw. I'll be repitching impeller for sure next spring, season is over here, I already winterized my fzr

  9. #9
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    Quote Originally Posted by Denis View Post
    thank you, Carlos! You guessed rpms right, about 7800 is max that I saw. I'll be repitching impeller for sure next spring, season is over here, I already winterized my fzr
    We have 3 more races in October/November here in California. You will be North of 80 mph and pull hard out of the whole with no cavitation.

  10. #10

    Join Date
    Apr 2010
    Location
    Vladivostok, Russia
    Posts
    65
    +1
    1
    Hope so. I would like to try H1 charger also before repitching impeller. Would have done that already, but my mechanic decided to experiment with me without asking and installed that wheel with stock charger shaft, not riva one I had. Well, it took just couple seconds of full acceleration before shaft broke and nut destroyed H1 wheel.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cam timing and compression testing, interesting results
    By Vern in forum 4-Tec Performance
    Replies: 121
    Last Post: 09-04-2015, 01:48 PM
  2. This weekend results with cam and Lucky 13 cone
    By raiderx72 in forum 4-Tec Performance
    Replies: 58
    Last Post: 05-07-2015, 09:28 PM
  3. Replies: 12
    Last Post: 03-14-2012, 12:53 AM
  4. Cam results? RR or PPG
    By spawn5150 in forum 4-Tec Performance
    Replies: 70
    Last Post: 04-13-2010, 08:40 PM
  5. Franks 80+ mph videos and results from Saturday
    By Enufpwr in forum 4-Tec Performance
    Replies: 16
    Last Post: 09-11-2008, 01:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •