Results 1 to 4 of 4
  1. #1

    Ultra 130di not running or hull in NY/NJ/PA/CT

    Does anyone have a non-running Ultra 130di or complete hull minus the motor in the NYC area?

    Thanks,
    Larry


  2. #2
    there was an ultra 150 hull fs on here a week or so ago...

  3. #3
    witness140's Avatar
    Join Date
    Aug 2010
    Location
    Northeast
    Posts
    140
    +1
    1
    I have a 2000 Ultra 150 hull in CT. Sitting in the garage. Stripped. What exactly do you need? I believe the 130's and the 150's share a common hull.

    Just checked parts nation and the 01' Ultra 130 and 01' Ultra 150 share a common PN. 59426. I would guess you are after a blue hull, which would be a 2001 Ultra 150.

    My 00' is red and isn't complete, as I've been parting it out.

  4. #4
    Thanks guys but i need the di fuel system and pump too.

    Sent from my DROIDX using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Just a reminder that section is for selling skis only not parts or hulls
    By OsideBill in forum Yamaha 2 Stroke Skis
    Replies: 4
    Last Post: 01-27-2016, 10:53 PM
  2. Ultra 260x not running right
    By jbizub in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 08-11-2015, 02:58 PM
  3. XP800 wont run or start in water
    By Boglin in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-12-2011, 03:31 PM
  4. We need a Poker Run or something in Jax Fl
    By f150vtx in forum Southeast
    Replies: 3
    Last Post: 02-25-2008, 09:36 AM
  5. ultra 150 only running 20 mph in water
    By jiggie in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-30-2007, 09:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •