Results 1 to 3 of 3
  1. #1

    94 sl750 MFD keep going bad

    I have replaced the MFD 3 times on my 94 sl750. It is the round type that is on the dash.
    I keep having them short out and blowing the fuse in the electrical box.
    What is the fix for this?


  2. #2
    Canadian Beaver Inspector jkindt's Avatar
    Join Date
    Sep 2009
    Location
    Lethbridge, AB, Canada
    Posts
    1,721
    Check your wire harness and plug end. Shouldn't get 3 bad ones in a row.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    What size fuse are you using for the MFD?
    Should be 1/4 Amp, no larger.

    When are the fuses blowing?
    When connecting the battery?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 02virage txi and 94 sl750 mfd/mfi units for sale
    By rm12577 in forum Polaris Classifieds
    Replies: 1
    Last Post: 03-17-2015, 06:44 PM
  2. 94 sl750 mfd
    By herkyfe in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 08-02-2013, 05:19 PM
  3. My fuel pump(s) keeps going bad.
    By gr4ph1c in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-15-2012, 09:10 PM
  4. FS 94 SL750 MFD for SBN rebuild kits
    By Slipknotanfitch9 in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-09-2011, 02:55 PM
  5. Why does Starter relay keep going bad?
    By camar0 in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-02-2008, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •