Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 71
  1. #1
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324

    Has anyone installed an MFI on a SL ski?

    I have a SL650 that I want to put some sort of an MFD on. Has anyone ever installed the newer MFI like used on a Virage on a SL? Does it use the same 8 pin harness as the oval MFD?

    Bryan


  2. #2
    Quote Originally Posted by BryanP View Post
    I have a SL650 that I want to put some sort of an MFD on. Has anyone ever installed the newer MFI like used on a Virage on a SL? Does it use the same 8 pin harness as the oval MFD?

    Bryan

    You can use a later MFI but I think they have the 12-pin connector.....but it's also easy enough to buy the propper 8-pin connector for a few bucks and swap it over.

    I picked up an MSX MFI the other day on ebay so I'll know more about it in a few days...

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Here is all the info that you will need.

    http://polarispwcknowledge.shorturl....nction-display

  4. #4
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698
    I plugged the mfi from my txi into my pro 785 harness and it wouldn't wake up. The mfi powers up when jumped off a battery

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by thester71 View Post
    I plugged the MFI from my TXi into my pro 785 harness and it wouldn't wake up.

    The MFI powers up when jumped off a battery
    MFI (Virage and Genesis only) uses different connector pin-outs than the 12-pin MFD.

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    A little pricey,but works well;
    http://cgi.ebay.com/ebaymotors/POLAR...item4aa4fa04e2

    or item # 320595428578

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by bgaidan View Post
    You can use a later MFI but I think they have the 12-pin connector.....but it's also easy enough to buy the proper 8-pin connector for a few bucks and swap it over.

    I picked up an MSX MFI the other day on ebay so I'll know more about it in a few days...
    MSX uses the NGI display type, not MFI.

    And there are two versions of the NGI display. One is for the MSX 140 (2-stroke), the other is for the MSX 110 and MSX 150 (4-stroke turbo).

    The 2-stroke NGI version has an oil level indicator, while the 4-stroke NGI has a 'turbo boost' indicator (fake, actually).

    The MSX hulls use a paddle wheel type speedometer sensor, not the pitot pressure tube of the MFD and MFI displays.

    The MFI displays (Virage and Genesis) do have all the same basic electrical signals as the MFD, just on different pins. You can swap the pins around for an MFD wire harness connector to fit the MFI display, both physically and electrically.

  8. #8
    The one I picked up is from an MSX 150. I just got it to play around with it...and because it was cheap.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by bgaidan View Post
    The one I picked up is from an MSX 150. I just got it to play around with it...
    Quote Originally Posted by beerdart View Post
    Here is all the info that you will need.

    http://polarispwcknowledge.shorturl....nction-display
    Have fun

  10. #10
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I am tempted by that kit on ebay, but I would rather have an oval MFD. Whats a fair price to get a working one for, or does anybody have one available?

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has anyone installed a headlight or nav lights on their ski?
    By VXRPete in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 09-16-2015, 07:21 AM
  2. Has anyone installed a battery switch on their Seadoo?
    By normr in forum 2-Stroke Performance
    Replies: 27
    Last Post: 12-17-2013, 07:14 PM
  3. has anyone installed a bov on fzr
    By jusloungin in forum Yamaha PWC Performance (4-stroke)
    Replies: 48
    Last Post: 03-17-2010, 09:33 PM
  4. Has anyone needed an EFI just with a jetworks holeshot kit?
    By jcorallo in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 11-09-2008, 08:24 AM
  5. Has anyone tried TDR waterbox on RXP
    By codymouse54321 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-05-2007, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •