Results 1 to 4 of 4
  1. #1

    gp1200r not charging

    was out riding the other day shut it off and cranked really slow then not at all . got towed back in and jumped it but tested it and it is not charging the battery. any suggestions before i tear it apart to get to the stator? thanks

  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Elephant Butte New Mexico
    likely the connector to the regulator or the regulator itself is toast..see my posts on this not take the stator out until you check the regulator and the voltage going into the regulator

  3. #3
    thanks i will check it out

  4. #4
    it was hte regulator charging now at 14 volts thanks alot

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Battery charging?
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 05-12-2009, 07:25 AM
  2. Charging System
    By VegasRatt in forum Polaris Open Discussion
    Replies: 5
    Last Post: 12-31-2007, 04:36 PM
  3. 95 XP charging problem
    By denrxp in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-25-2007, 12:04 AM
  4. 04 rxp not charging
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-26-2007, 07:33 PM
  5. Charging issue...
    By meeper in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-30-2006, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts