Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32

    Angry Help with SC removal 08 PX

    O.K. So I'm pulling the SC following the "how to" instructions that were posted. I'm at the point where you move the waterbox back for SC removal clearance, but my waterbox set-up is different. I have it all unclamped, hose removed, and can rotate it freely , but the GD thing won't pull back!
    Any suggestions???? How are you guys with X's moving it out of the way?
    Does it even need to be moved?


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You have to loosen those big clamps around the midpipe that are next to the manifold. I never removed my SC with the stock box on so Im not sure if you even have to move it. Try taking off the SC first and see if you dont have the room.

  3. #3
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    You need to slide the exhaust back a little to get the charger out. You will need to unhook the bungee holding it in place, would recommend leaving it hooked on the port side because it's a pain getting hooked back up. Like OC said, unclamp the big clamps.

  4. #4
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    All of the clamps are removed, along with the strap and hose.

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by sn-95 View Post
    All of the clamps are removed, along with the strap and hose.
    So get that mofo out bro. Dont be afraid to use some force, all those components are tough.

  6. #6
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by Ocman View Post
    So get that mofo out bro. Dont be afraid to use some force, all those components are tough.
    I must be retarded. I just found the clamp it showed in the how to that I thought wasn't there. Hopefully that does the trick.

  7. #7
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32

    Red face

    It's official.... I am an idiot.

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by sn-95 View Post
    It's official.... I am an idiot.
    Check out your gold washers really well and post some pics. You gonna adjust your slip while its out Im assuming??

  9. #9
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    It looks good! I still have to check slip, but I don't anticipate an issue.
    The one pic shows the clamps right off the waterbox where I was trying to take it apart. "not recommended"LOL. After I got it apart, the rear SC screw rounded off while using a 1/4 open end wrench to try and loosen it "another NOT RECOMMENDED"..........3 hours later I cut it off.
    Quick question, Do all those tie wraps around the hoses actually do anything? If not, I'm leaving them off.
    Thanks for the help, Ocman you were right on brother.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN2657.jpg 
Views:	46 
Size:	62.0 KB 
ID:	215279   Click image for larger version. 

Name:	DSCN2655.jpg 
Views:	55 
Size:	113.1 KB 
ID:	215280  

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by sn-95 View Post
    It looks good! I still have to check slip, but I don't anticipate an issue.
    The one pic shows the clamps right off the waterbox where I was trying to take it apart. "not recommended"LOL. After I got it apart, the rear SC screw rounded off while using a 1/4 open end wrench to try and loosen it "another NOT RECOMMENDED"..........3 hours later I cut it off.
    Quick question, Do all those tie wraps around the hoses actually do anything? If not, I'm leaving them off.
    Thanks for the help, Ocman you were right on brother.
    Next time remove the sensor from the head and it will give you much more room to reomve top sc bolt.
    Attached Images Attached Images    

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with modding my 08 RXP 215
    By AthleticKid818 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-12-2009, 07:53 PM
  2. Help with pump removal on '01 GPR
    By Ziggy in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-30-2009, 05:02 PM
  3. Help with SC issue I have....
    By Suthrn in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-29-2008, 12:48 PM
  4. Need Help with HEAD removal 06 RXP
    By sr71bb in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-25-2006, 02:06 PM
  5. Help With sc Clutch
    By bayline03 in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-17-2006, 02:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •