Results 1 to 7 of 7
  1. #1
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250

    Pump Alingment Question

    What is a good way to check the pump and shaft alignment if you don't have the alignment tool?


  2. #2
    Pho got this from Randy? anyway pull your drive shaft remove the bumpers at both ends reinstall and then slide the shaft back and forth into the coupler it should not bind! then try rotating the motor and check a few different positions! It's not the best but will verify issues to some degree! Z

  3. #3
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250
    Thanks Z... that kind of what i did... just seeing if it was good enough

  4. #4
    what do you mean by bind??

  5. #5
    what do you mean by bind? not align shaft could cause cavitation??

  6. #6

    Shaft alignment

    A alignment issue between the motor and pump can cause premature wear of the pump,impeller splines,coupler splines,driveshaft splines and bushing. Z

  7. #7
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250
    Andy, i think binding up would be the shaft having a hard time going into or coming out of the coupler. They should move in and out without any kind of hang up.

    Good input about cavitation too, thanks.

    RATT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pump Wedge Question
    By GRNGOBLIN in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-01-2006, 12:48 PM
  2. Pump Wedge Question
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-27-2006, 08:21 PM
  3. pump support question
    By Tiplickhahaha in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-02-2006, 02:52 PM
  4. (Damaged) Pump Support Question
    By Snoman in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-13-2006, 06:37 AM
  5. Pump install question.
    By Mark S in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-01-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •