Results 1 to 10 of 10
  1. #1

    GP 1200 R - Never ending beep.

    Hi!

    I have been googling the last few days trying to find a solution to my problem. Via google did I find this site and it seems that you folks know more about jetskis than the other sites, so I decided to join up and perhaps you can help.

    I have a 2002 GP1200R Waverunner with around 120 hours on the clock. We jetski every friday afternoon for about 3-4 hours. About 3 weeks ago, we were at the beach and having some fun when out of nowhere, the bike started to emit a loud, ear piercing, never ending beep.

    At first I thought the bike was overheating as this must be the most extreme alarm that the bike can emit when something goes wrong. And in my books, overheating is the worst that can happen to the engine.

    This beeping continued even while the engine was off. I had to disconnect the battery for it to stop. I removed the seat and the engine was not hot at all. No steam comes off it when I drop water drops on it. Same for the exhaust system.

    I messed around a bit and found that my instrument display panel was not working at all, and therefor the reset button wouldn't work. I am not sure that this would cause the sudden cause for alarm, but it might be.

    A week or so ago, I opened up the seat and started to check around now that the engine is dry and all cables (if they were exposed to water) are also dry. The moment I connect the battery, the beeping noise start immediately.

    I have googled my ass off and read manuals but I couldn't find anything related to my problem. Some say its temperature, some say it's oil (I bypassed the oil tank and use premix. I have used this for over a year) etc. I have given it to the repair center but I don't want them to screw me over, simply because I don't know enough about jetski engines.

    I have sufficient knowledge about engines (for cars).

    Any help in this regard will be appreciated.


  2. #2
    The speaker is at the base of your steering column. Trace the wire and unplug it.

  3. #3
    Quote Originally Posted by Powerslave View Post
    The speaker is at the base of your steering column. Trace the wire and unplug it.
    I can do that, but how will I know if something is wrong with the bike?

  4. #4
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Unplug the wire from the gauge. See if you have any corrosion. See if you can get the gauge cluster back up and working. If you can get it working. hold the reset button after you turn the ski on and off and it will give you a code or number. see what the number is and post back. Lee

  5. #5
    Ok, the bike is at the service center. It's not official, just some guy who fixes it in his spare time. Ill go over there tomorrow and have a look.

  6. #6
    Quote Originally Posted by StephanBotha View Post
    I can do that, but how will I know if something is wrong with the bike?
    I was assuming that you had looked it over already and checked for codes. If you dont see anything that is obviously wrong and it runs ok, yank that sucker out.

  7. #7
    Hi guys,

    Just a quick reply to say we have fixed the bike. Turns out it was a short that caused the bike's alarm system to go off.

    Bike is fixed and rides like a dream again

  8. #8
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    Quote Originally Posted by StephanBotha View Post
    Hi guys,

    Just a quick reply to say we have fixed the bike. Turns out it was a short that caused the bike's alarm system to go off.

    Bike is fixed and rides like a dream again
    Good news
    will you be sticking around and catching the modding bug....

  9. #9

    Join Date
    Jul 2009
    Location
    Nor Cal
    Posts
    85
    Quote Originally Posted by Hydrotherapy View Post
    Good news
    will you be sticking around and catching the modding bug....
    LoL...wouldn't be surprised if he did

  10. #10

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 gp 1200 bogging on top end, w. Temp light flashing
    By [email protected] in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-13-2016, 04:44 PM
  2. Top end replacement / 97 gp 1200
    By CDW78 in forum Yamaha Old School Skis
    Replies: 43
    Last Post: 04-30-2013, 07:16 PM
  3. gp 1200 r beeping but won't run
    By stealthbomber87 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-27-2012, 09:28 PM
  4. Top end rebuild 98 gp 1200
    By rexzazo in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 09-05-2008, 08:24 AM
  5. GP 1200 carburator on Venture 1100 help me?
    By dre23 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 11-22-2005, 12:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •