Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    code 18 on 03 gp1300r

    Hows everyone doing, I have a 2003 gp1300r with stage II , I am getting a code 18 which is the throttle position sensor. when started it wont idle stays at mid rpms. Has anyone messed with the sensor? can it be adjusted? or could it be something else? Thanks


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by jonf View Post
    Hows everyone doing, I have a 2003 gp1300r with stage II , I am getting a code 18 which is the throttle position sensor. when started it wont idle stays at mid rpms. Has anyone messed with the sensor? can it be adjusted? or could it be something else? Thanks
    You need the YDS software to read and adjust the sensor. They just dont go out of adjustment. Check the controller and wiring. Check all plugs and harness connections. I have had a few controllers with $hitty connectors and the wires pulled out of the back.

    http://www.greenhulk.net/forums/show...iva+controller
    Last edited by WFO; 10-26-2006 at 10:10 AM.

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Oh, and Welcome to the forum !!!

  4. #4
    Thanks. Do the sensors ever go bad? or is it normally the wiring? I have had some wiring work done recently. I am not sure where to start . any suggestions?

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    I havent seen the sensors actually go bad. I have seen "dead" spots in the sensor. But then again, I have only worked on a few with running problems. Its basically a variable resistor (TPS).

    Unfortunately with electrical diagnosis you start at one end of a circuit, and work your way to the other. Checking wiring for opens as you go. If you had some electrical work done recently, than I would start with that location.

    If you have a dealer close to you, they can plug in and read the TPS voltage at the ECU to see if it is in fact is is bad.

  6. #6
    Thanks. I guess i will start at the harnness. Unfortunately none of the dealers around here will help you. and if they do plan on spending alot of money.

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Where are you located ?

  8. #8
    jupiter, florida

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    If you cant figure it out, give Jim a call. He is Jims1300 here on the forum. He has a shop in Palm Harbor.

    Good luck

  10. #10
    I have been talking to him too. Very helpful. If i cant figure it out i will have to take it to him. this ski has had nothing but problems. Thanks again.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Error code 13 on 2003 gp1300r
    By Kal2539 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-31-2013, 04:59 PM
  2. Gutting stock airbox on 03 gp1300r
    By juan valdez in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-19-2012, 04:40 PM
  3. Can't find the speed on my 03 gp1300r
    By mastice in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 08-12-2007, 10:17 PM
  4. leak on 03 gp1300r
    By teamyam613 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-07-2007, 08:46 PM
  5. Code 53 on GP1300R
    By jfoster in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-04-2006, 04:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •