Results 1 to 10 of 10
  1. #1

    Join Date
    Aug 2010
    Location
    Gold Coast, Australia
    Posts
    12

    Seadoo Wake 2008 (RXP) 215 HP Supercharged. Water damage. Help needed.

    Hi I have a 2008 Wake 215hp supercharged which has suffered water damaged to the pins and plugs on the A and B plugs on the ECU. They were badly corroded and after cleaning them up and replacing 6 of the female connectors in the A connector and 3 in the B conector I am only getting a click from the relay by the fuse box and a ticking from the fuel pump and that is intermittent if I wiggle the B connector. There is no display from the gauges and nothing from the start button. I am thinking that I am going to have to replace the ECU as the water across the pins may have caused a short and blown something in the ECU and maybe also the wiring harness needs to be replaced so that I replace the A and B connectors as well. I can get a neww ECU part # 420665789 from the US for approx $700 . Does anyone have any thoughts on how I should proceed with this or any ideas on sourcing new or used parts to repair. Any help would be much appreciated. Thanks ,John.


  2. #2
    Check your wiring harrness for continunity, do you have the tool to be able to plug into A & B connectors?

  3. #3
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    If I were you I will clean all the connectors and grounds first, check fuses and relays for corrosion then if nothing works I will try an ECU and take it from there..

  4. #4

    Join Date
    Aug 2010
    Location
    Gold Coast, Australia
    Posts
    12
    No do not have the connector checking tool?

  5. #5

    Join Date
    Aug 2010
    Location
    Gold Coast, Australia
    Posts
    12
    Have cleaned corrosion from contacts and checked relays and replaced some of the fuses which were blown, so maybe its a neww ECU next ??

  6. #6

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    226
    Quote Originally Posted by luckyjohn View Post
    Have cleaned corrosion from contacts and checked relays and replaced some of the fuses which were blown, so maybe its a neww ECU next ??
    You say there is a clicking when you try to start it. Did the starter solenoid get wet too? Perhaps the solenoid contacts are corroded as well and the clicking is the contacts in the solenoid?? Worth a check before you start pulling the ECU.

  7. #7

    Join Date
    Aug 2010
    Location
    Gold Coast, Australia
    Posts
    12
    Solenoid is ok. Nothing at all happens when starter pushed.Noise comes from pump as soon as DES is attached. Thanks.

  8. #8
    Hi, there. Want to buy Sea Doo engine ECU (ECM), part # 420665789. Fits almost all Sea Doo's year 2008-2009. Does someone have this part or can get one for me? Thank you.

  9. #9
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    257
    +1
    5
    May be the dess post

  10. #10

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    779
    +1
    39
    I have 2 harnesses and a 155 ecu of needed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 08-21-2014, 08:44 PM
  2. Seadoo Wake 2008 Model Wake 215hp Supercharged - ECU Problem
    By luckyjohn in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-16-2014, 05:11 PM
  3. Replies: 9
    Last Post: 07-14-2012, 06:16 PM
  4. WTB 2005 SeaDoo RXP 215 HP 4-TEC Program Module CPU CDI
    By RNX in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-16-2011, 01:16 PM
  5. RXP 215 hp 2008 #1 wiring Harness
    By luckyjohn in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-25-2011, 01:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •