Results 1 to 6 of 6

Thread: rpm drop

  1. #1

    rpm drop

    hey, this happened a few weeks ago. i was going full out and the rmps dropped to 7200, it will rev to 7500, it has 22 hours... i took it to the dealer and they said theres nothing wrong with it.,.. any ideas?
    Last edited by Snoman; 10-01-2010 at 09:37 AM.


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by eythan poirier View Post
    hey, this happened a few weeks ago. i was going full out and the rmps dropped to 7200, it will rev to 7500, it has 22 hours... i took it to the dealer and they said theres nothing wrong with it.,.. any ideas?
    Welcome to the forum,

    use the search and you will find some threads with your same issues.

    Also would need more info as you have not indicated what ski, etc.

    Too many possibilities to list but since you asked be sure your not running stock washers in your charger if you have one .

    Good luck!
    Last edited by skoepp; 10-01-2010 at 05:40 PM.

  3. #3
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by eythan poirier View Post
    hey, this happened a few weeks ago. i was going full out and the rmps dropped to 7200, it will rev to 7500, it has 22 hours... i took it to the dealer and they said theres nothing wrong with it.,.. any ideas?
    I would check for a boost leak. Check to see if the SC to IC and IC to TB hoses are secure and the clamps are tight. And replace your sparkplugs.

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by skoepp View Post
    Welcome to the forum,

    use the search and you will find some threads with your same issues.

    Also would need more info as you have not indicated what ski, etc.

    Too many possibilities to list but since you asked be sure your not running stock washers in your charger.

    Good luck!
    More details please.

    What ski is it?

    Your problem can be as simple as seaweed in your intake grate or a boost leak...just need more info.

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by Craigo View Post
    I would check for a boost leak. Check to see if the SC to IC and IC to TB hoses are secure and the clamps are tight. And replace your sparkplugs.
    We dont even know if he has a boosted ski yet

  6. #6
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by mrbtd View Post
    We dont even know if he has a boosted ski yet
    You need to check his profile. I did.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stage 2 GP12R RPM drop at WOT
    By Himes in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 05-27-2010, 11:05 PM
  2. Help 07 Sc Wake Rpm Drop While Surging
    By Scotty in forum 4-Tec Performance
    Replies: 13
    Last Post: 10-10-2007, 10:20 PM
  3. How much RPM drop when upgrading props?
    By VX1 in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-05-2007, 04:12 PM
  4. 13/18 Solas/SS Wear Ring = 700 rpm drop from stock 10/21 :(
    By clpsuite in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-09-2007, 09:00 PM
  5. Loss Of Power/RPM Drop
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-26-2007, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •