Results 1 to 5 of 5
  1. #1
    mike1706's Avatar
    Join Date
    Dec 2008
    Location
    ,Florida
    Posts
    1,691
    +1
    16

    i need help please?

    Click image for larger version. 

Name:	3.jpg 
Views:	51 
Size:	39.6 KB 
ID:	216135today i took out my pump on my gpr and i noticed that it has like some mark, like if the bearing on the intermiddle shaft is eating the metal. So my question is i'm using a 1300 gpr pump but i missing the 2 inch spacer, cause i have the 1200gpr cables (the steering, and trim) could i damage my inter middle shaft. I will post some pic.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by mike1706 View Post
    Click image for larger version. 

Name:	3.jpg 
Views:	51 
Size:	39.6 KB 
ID:	216135today i took out my pump on my gpr and i noticed that it has like some mark, like if the bearing on the intermiddle shaft is eating the metal. So my question is i'm using a 1300 gpr pump but i missing the 2 inch spacer, cause i have the 1200gpr cables (the steering, and trim) could i damage my inter middle shaft. I will post some pic.
    Picture not that clear but that looks like were the 2 o rings ride on the drive shaft.

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    Picture not that clear but that looks like were the 2 o rings ride on the drive shaft.
    +1

    thats where the I shaft O rings ride

  4. #4
    mike1706's Avatar
    Join Date
    Dec 2008
    Location
    ,Florida
    Posts
    1,691
    +1
    16
    yeah but it look like the metal is eating the shaft my problem is that i put a gp1300r pump on my 2001 gpr but with out the 2 inch extension. does that affect on my inter middle shaft having the gp1300r pump on without the 2 inch extension. Could the shaft on the pump be to long and could damage something else. please really need help on this

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by mike1706 View Post
    yeah but it look like the metal is eating the shaft my problem is that i put a gp1300r pump on my 2001 gpr but with out the 2 inch extension. does that affect on my inter middle shaft having the gp1300r pump on without the 2 inch extension. Could the shaft on the pump be to long and could damage something else. please really need help on this
    GPR driveshafts are all the same except for 2002... difference is the intermediate

    thats normal high hour wear... really need to replace that driveshaft to keep water from getting into the intermediate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to polaris need help please
    By pepp101 in forum Polaris Projects
    Replies: 22
    Last Post: 07-30-2007, 02:15 PM
  2. 96 SL900 Uh Oh Need HELP Please
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-16-2007, 11:58 PM
  3. Need Help Please!!!!!! On Prop Choice
    By MB VIP in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-10-2007, 08:41 AM
  4. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  5. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •