Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: prop lose

  1. #1
    abie_lah's Avatar
    Join Date
    Jul 2009
    Location
    Kuala Terengganu, Malaysia
    Posts
    264

    prop lose

    my propeler always lose,, what is prob?? shaft,, prop or pump shaft???


  2. #2
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    not a good sign. mine came lose, ate the thrust washer, crank and block. check your oil filter and see if you see any metal in the bottom. if not you may have gotten lucky

  3. #3
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Torque to 130 nm,mine never came loose.
    Check the thread on the bolt which holds the impeller in the pumphousing.
    Maybe the thread is damaged,make sure to check thread on impeller also.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,514
    +1
    1,258
    clean prop and pump shaft with solvent, allow to dry, apply plenty of high strength threadlock, pull tight till your arm hurts and then LET IS SIT FOR 24 hours. Threadlock needs time to cure, and if your threads are questionable, anything less is going to result in the prop backing off, specially if you rev it up a few times on the hose. When you chop the throttle there are serious momentum forces working to unscrew your prop.

    and as mentioned..a loose prop is going to mean really big trouble..in a very short time.

  5. #5

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Quote Originally Posted by Mike H View Post
    not a good sign. mine came lose, ate the thrust washer, crank and block. check your oil filter and see if you see any metal in the bottom. if not you may have gotten lucky
    Listen to Mike, he knows what he's talking about!

  6. #6
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    If all the threads are good on the shaft & impeller, Crank it down to 95 - 100ft/lbs WITHOUT any loctite. You can mess up the threads when trying to get it back off if you use loctite, Unless you heat it up with a torch from the impeller nose side..

  7. #7
    abie_lah's Avatar
    Join Date
    Jul 2009
    Location
    Kuala Terengganu, Malaysia
    Posts
    264
    thanks fot all suggestion,, now that ski must be general overhoul coz engine cannot crank,, coz waterblock,, huhuhuhu

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by ou812 View Post
    If all the threads are good on the shaft & impeller, Crank it down to 95 - 100ft/lbs WITHOUT any loctite. You can mess up the threads when trying to get it back off if you use loctite, Unless you heat it up with a torch from the impeller nose side..

    +1..I have 2 RXPs and have never used loctite on either prop and I have never had a prop back off..

  9. #9
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I use anti-seize because thats what solas calls for. I also have never had an impeller loosen on me

  10. #10
    Norwegian Wiking Trond's Avatar
    Join Date
    Nov 2007
    Location
    Norway, Kristiansand
    Posts
    1,456
    Quote Originally Posted by GGG View Post
    I use anti-seize because thats what solas calls for. I also have never had an impeller loosen on me
    +1

    I just torque it hard... But i have had it come of when i did not torque it hard enough...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. solas prop compared to stock repitched
    By nitro rxp in forum 4-Tec Performance
    Replies: 23
    Last Post: 12-17-2007, 10:31 AM
  2. solas prop
    By nitro rxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-08-2005, 09:54 PM
  3. Have stage I minus the prop, looking for more mods..
    By 05rxt in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-08-2005, 07:07 AM
  4. SRX-CD 13/19 RXT Prop avail at Riva
    By UFO-RXT in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-05-2005, 12:21 AM
  5. 4-TEC props
    By Phil in forum 4-Tec Performance
    Replies: 51
    Last Post: 05-26-2005, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •