Results 1 to 5 of 5
  1. #1

    Join Date
    Oct 2010
    Location
    Boston, MA
    Posts
    4

    GP800r instrument cluster

    Anyone know a good location to purchase a used cluster for my 2002 GP800r, the gauges got wet. So now the warning chime sounds often and I cannot read the gauges. I am fairly new to the watercraft industry and not sure if anyone sells used parts? The part number is F0W-6820A-00-00


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by MChristiansen View Post
    Anyone know a good location to purchase a used cluster for my 2002 GP800r, the gauges got wet. So now the warning chime sounds often and I cannot read the gauges. I am fairly new to the watercraft industry and not sure if anyone sells used parts? The part number is F0W-6820A-00-00
    I think forum member skittb has one maybe shot him a PM.

  3. #3
    Thanks for the recommandation Jim but oddly enough I just sold the one I have today.

  4. #4

    Join Date
    Oct 2010
    Location
    Boston, MA
    Posts
    4
    Hey thank you guys, if you come across another let me know. May I ask what you sold yours for scittb? Just wondering what a used one is worth, new one is like $420.......

  5. #5
    Pretty much gave it away at 130 shipped. Usually for a mint condition one I think I had paid 200 for one because it was the middle of the summer. All about timing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to remove instrument cluster on GP800R
    By HotChiliRam in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-21-2012, 07:37 PM
  2. 03' 1300 Instrument Cluster
    By KEN275 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-30-2008, 11:26 PM
  3. Instrument Cluster
    By Jetsam in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-05-2008, 11:41 PM
  4. 2002 seadoo 4tec instrument cluster
    By gyroav8r in forum 4-Tec Performance
    Replies: 0
    Last Post: 11-04-2007, 08:05 AM
  5. Strange electrical problem -- instrument cluster going crazy
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-06-2006, 05:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •