Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 36
  1. #1

    Join Date
    Sep 2010
    Location
    Hammonton, NJ
    Posts
    20

    Angry Why Do They Smoke So Much?

    Probably a re-post, if so , sorry. Did a search, but wasn't satisfied. Has anyone here solved the reason why the Polaris PWC smoke more than any other ski regardless of age or make? A dealer once told me that that was one of the negatives that turned people off on Polaris and kept sales low enough to get out. You can always tell a Polaris coming at you by the abnormal amount of smoke at low speed, (no wake zones). And yes, it always is more than the other brands. You never see a 95 or 96 Ski Doo or Yamaha 2 stroke smoke like these. Is there a fix?


  2. #2
    TopCop931's Avatar
    Join Date
    Apr 2010
    Location
    Nutley, NJ
    Posts
    520
    Quote Originally Posted by topgun View Post
    Probably a re-post, if so , sorry. Did a search, but wasn't satisfied. Has anyone here solved the reason why the Polaris PWC smoke more than any other ski regardless of age or make? A dealer once told me that that was one of the negatives that turned people off on Polaris and kept sales low enough to get out. You can always tell a Polaris coming at you by the abnormal amount of smoke at low speed, (no wake zones). And yes, it always is more than the other brands. You never see a 95 or 96 Ski Doo or Yamaha 2 stroke smoke like these. Is there a fix?
    I don't know if it kept sales low but my best guess is the oil injection system that may cause a little more smoke than the others that you have mentioned. My 780 doesn't smoke much at all in the no wake zones. It does smoke a lot when first started on the trailer (AGAIN I THINK IT IS THE OIL INJECTION) but the smoke dissipates quickly. Honestly, the only time I notice more smoke than usual is my first ride after a good flush and fogging.

    2 Strokes smoke whether you're running premix or the injection system. Some oils will cause more smoke also.

  3. #3

    Join Date
    Sep 2010
    Location
    Hammonton, NJ
    Posts
    20
    Quote Originally Posted by TopCop931 View Post
    I don't know if it kept sales low but my best guess is the oil injection system that may cause a little more smoke than the others that you have mentioned. My 780 doesn't smoke much at all in the no wake zones. It does smoke a lot when first started on the trailer (AGAIN I THINK IT IS THE OIL INJECTION) but the smoke dissipates quickly. Honestly, the only time I notice more smoke than usual is my first ride after a good flush and fogging.

    2 Strokes smoke whether you're running premix or the injection system. Some oils will cause more smoke also.
    That's what I have, a SLX 780. Mine smokes so much in no wake zones that it's embarressing. My brother in laws 750, the same. I tried everything. Running with or without the thermostst, changing the oil check valves on each carb, using different full synthetic oils and even Blu Marble. You are so lucky yours doesn't smoke much.

  4. #4
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    are you running premix or on oil pump?. Maybe you oil pump is failing and pumping full out

  5. #5
    TopCop931's Avatar
    Join Date
    Apr 2010
    Location
    Nutley, NJ
    Posts
    520
    Quote Originally Posted by topgun View Post
    That's what I have, a SLX 780. Mine smokes so much in no wake zones that it's embarressing. My brother in laws 750, the same. I tried everything. Running with or without the thermostst, changing the oil check valves on each carb, using different full synthetic oils and even Blu Marble. You are so lucky yours doesn't smoke much.
    Are you guys using fuel additives? Some of them will cause smoke issues.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,277
    Quote Originally Posted by topgun View Post
    ... SLX 780. Mine smokes so much in no wake zones that it's embarrassing. My brother in laws 750, the same.

    I tried everything. Running with or without the thermostat, changing the oil check valves on each carb, using different full synthetic oils and even Blu Marble...
    Have you checked the oil pump to throttle linkage?

    The oil pump system on 1995+ Fuji engines is variable flow rate. There is a linkage to the carbs (Item 5 in the 1995 SLX 780 diagram) that allows the throttle position to control how much oil the system pumps at low-mid RPM.

    If the link rod falls off or becomes loose, the oil pump drops to a fail safe position where it pumps oil at maximum flow rate. This protects the engine, but will cause excess exhaust smoke.



    Also, are you sure the carburetors are operating and adjusted properly for low throttle? Excess richness in the low speed carb settings will cause smoke.

    Have the carbs been rebuilt?

  7. #7
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I know sometime in the 90s I forget which model or year but polaris had a problem with oil starvation. Knowing polaris, they probably fixed the problem with overkill

  8. #8
    what oil are you running? if i run polaris oil than SMOKE, but AMSOIL is what i run all the time now and very much less smoke

  9. #9
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    If you have triple pipes like on a pro785 noone looks at the smoke, they just stare from the sound coming.lol I dont mind it smoking myself.. thats telling me its getting oil. Once the ski warms up, its not too bad. Love that R-50!. I put it in my weed whacker!.


    Polaris got sued for replicating a hull design from another manufacturer and got a court injunction against them to stop making skis for 4 years. thats why they got out of it.

    I stand corrected. i was thinking of the donzi hull years back.. it was for a efi invention on snowmobiles...

    I thought I did hear somewhere they couldnt make skis for 4 years too.. cant remember where I heard that from..maybe it was for snowmobiles.. even still. thats too bad for polaris..
    Last edited by bowsniper; 10-06-2010 at 02:37 PM.

  10. #10
    TopCop931's Avatar
    Join Date
    Apr 2010
    Location
    Nutley, NJ
    Posts
    520
    Quote Originally Posted by K447 View Post
    Have you checked the oil pump to throttle linkage?

    The oil pump system on 1995+ Fuji engines is variable flow rate. There is a linkage to the carbs (Item 5 in the 1995 SLX 780 diagram) that allows the throttle position to control how much oil the system pumps at low-mid RPM.

    If the link rod falls off or becomes loose, the oil pump drops to a fail safe position where it pumps oil at maximum flow rate. This protects the engine, but will cause excess exhaust smoke.



    Also, are you sure the carburetors are operating and adjusted properly for low throttle? Excess richness in the low speed carb settings will cause smoke.

    Have the carbs been rebuilt?
    I thought about that bar also because I remember reading that it tends to bend also, but when I read that he said that his brother-in-law is having the same problem I started to think it has to be something in common that they are both using.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vipec and Athena. Why do they look identical???
    By Water4fire in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-12-2015, 12:05 AM
  2. so Jim...why do I want one?
    By Rio Vista in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-14-2007, 05:33 PM
  3. There's only so much a helmet can do...
    By ou812 in forum Open Discussion
    Replies: 9
    Last Post: 05-16-2007, 08:10 PM
  4. This is why i'm on the forum so much!
    By 01xdime in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-19-2007, 05:18 PM
  5. metal washers, why so much $$?
    By 1ton in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-27-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •