Results 1 to 3 of 3

Thread: polaris slt 750

  1. #1

    Question polaris slt 750

    I just bought an old slt 750 95 ,,motor and inside impecable!! outside well needs a little help but new mats and good cleaning will do the job.
    anyway 135 compression on all three fuji's and sounds great when running ,,no ticking ,,no weird noises from motor at all ,,$1200 with double trailer ,,cool price .
    BUT !! i have a clanging sound coming from pump when idling??
    normal?? never had a polaris before!


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I do believe its normal, and it will go away when its put in the water.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by craneman View Post
    I just bought an old slt 750 95 ,,motor and inside impeccable!! ... sounds great when running ,,no ticking ,,no weird noises from motor at all ...
    The rattly noise from the jet pump while out of the water is normal on Polaris, but that doesn't mean you don't have work to do

    It is worth your while to remove the jet pump and inspect the bearings for slop or grittiness. Inspect the impeller, and consider changing the through-hull seals while you have the drive shaft out.

    Inspect the drive splines at both ends, then grease the splines and put it all back together.

    THEN go over the engine. Have a look at the links below

    It is worth your while to spend some time now to inspect everything and do the maintenance, rather than have something expensive fail minutes or hours later on t he water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris SLT 750
    By GrantBlaz in forum Polaris Open Discussion
    Replies: 7
    Last Post: 02-20-2009, 09:48 AM
  2. Question for a Polaris slt 750
    By Rodney in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 08-10-2007, 12:25 AM
  3. Polaris SLT 750 - Where do you mount the fuel pump?
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-28-2007, 07:54 PM
  4. Polaris SLT 750 X Problems!
    By publiccraze in forum Polaris PWC Performance
    Replies: 7
    Last Post: 06-25-2007, 11:59 PM
  5. 95 polaris slt 750 no spark
    By The Joker in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 11-20-2006, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •