Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: 951 problem

  1. #1

    951 problem

    What would cause a 951 to turn over fine without sparkplugs but act up turning over with them? Its not the battery or starter either those have both been replaced. Any ideas?


  2. #2
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    whats your compression? sounds like a battery/starter problem.

  3. #3
    Compression was fine when we bought it but we can't even check it now cause the engine sputters with the tester in. We did test it when we took delivery of it though and it was perfect

  4. #4
    badjoka's Avatar
    Join Date
    Jun 2009
    Location
    Fairfield, CT
    Posts
    1,387
    +1
    122
    Quote Originally Posted by Joe Stang View Post
    whats your compression? sounds like a battery/starter problem.
    +1

  5. #5
    like i said both have been replaced with good ones

  6. #6

    Join Date
    Aug 2010
    Location
    Phoeniz, Arizona
    Posts
    9
    Compression was fine when we bought it but we can't even check it now cause the engine sputters with the tester in. We did test it when we took delivery of it though and it was perfect
    That sounds weird .
    try to see if the starter in the right position see if
    those bolts are needing to be tighten.
    Maybe a ground got lose ?

  7. #7
    badjoka's Avatar
    Join Date
    Jun 2009
    Location
    Fairfield, CT
    Posts
    1,387
    +1
    122
    Where did you get the starter from? I had the same problem in my kawi; I checked all the connections, solenoid, and battery but the ski would not start normally under load. I exchanged each component with a known working ski and had no problem, turned out the cheap but new starter I purchased from ebay was the culprit.

  8. #8
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by tumblingtwerp9 View Post
    What would cause a 951 to turn over fine without sparkplugs but act up turning over with them? Its not the battery or starter either those have both been replaced. Any ideas?



    Inspect battery cables and check for bad ground. Make sure battery is fully charged. Inspect solenoid and try jumping it over. Make sure the pump is not seized.

  9. #9

    Join Date
    Aug 2010
    Location
    Phoeniz, Arizona
    Posts
    9
    That Too could be it that the pump is seized ..

  10. #10
    The pump turns over fine on its own and I pulled the engine and the engine turns over fine once its out of the ski so I'm thinking something electronic is messing up

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PROBLEM 98 gsx 951
    By sleeplessnMS in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-22-2009, 12:54 AM
  2. 951 starter problem?
    By tomgtv in forum 2-Stroke Performance
    Replies: 3
    Last Post: 03-07-2009, 03:42 PM
  3. 951 DI motor problem 4900 RPM
    By kirkky in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-05-2008, 06:50 PM
  4. 98 GSXL 951 Acceleration Problem
    By radeon in forum 2-Stroke Performance
    Replies: 24
    Last Post: 08-02-2008, 07:56 PM
  5. 98 Gsx 951 Limited Problem
    By flyngixxer in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-20-2007, 07:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •