Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303

    WTF Hapenned to my driveshaft? *pics*

    So ive noticed a slight cavitation out of the hole on my 97XP. So I figured its time for a wear ring. Pulled the pump to find only half the splines left on the driveshaft. the other half has become forged into the impeller. There is BARELY enough splines left to stick the impeller removal took in there. How does somthing like this happen and how would one prevent it from happening again??


    I will now be in the market for a Impeller & Driveshaft
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1175.jpg 
Views:	53 
Size:	49.3 KB 
ID:	216801   Click image for larger version. 

Name:	IMG_1174.jpg 
Views:	50 
Size:	42.0 KB 
ID:	216802   Click image for larger version. 

Name:	IMG_1173.jpg 
Views:	56 
Size:	111.1 KB 
ID:	216803  


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    hard to tell from pics but is there still a chunk inside the impeller?
    I got a spare shaft that came off a gsx, give me the measurements of that one.

  3. #3
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Im thinking that was caused by lack of grease on the splines. usually they just strip out but yours looks like it rusted until it was weak enough to snap

  4. #4
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Yeah man there is the end of the driveshaft that snapped off welded into the impeller. Ive never had the pump off before. Havnt had the ski long. Im surprised it still ran fine and wasnt striping what splines were left grabbing the impeller??

    Whats left of the driveshaft is 20 1/4 inches. Hard to say how long it was originally? Will a drive shaft from GSX fit a rear shaft on a XP?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1178.jpg 
Views:	57 
Size:	76.4 KB 
ID:	216805   Click image for larger version. 

Name:	IMG_1179.jpg 
Views:	57 
Size:	104.4 KB 
ID:	216806  

  5. #5
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    this one is 18 inches, so it wont work. sorry bro

  6. #6
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    the cavitation you were having was probably really the splines slipping and i think the gsx shaft only fits the older style xp like 96. You dont even have an impeller shaft seal on there. once the splines dry out its only a matter of time before something bad happens

  7. #7
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    all of the splines are the same on all the 2 stroke engine, the impeller tool fits all models except the 4 tecs.
    it even fits a honda 4 stroke

  8. #8
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Quote Originally Posted by GGG View Post
    the cavitation you were having was probably really the splines slipping and i think the gsx shaft only fits the older style xp like 96. You dont even have an impeller shaft seal on there. once the splines dry out its only a matter of time before something bad happens
    The rubber nose cone seal was on there. I remove them when taking the impeller out of the pump. Most likely never got greased whoever had it apart last....

    Well Im looking for a driveshaft,core impeller, and also need a rectifier! Found out thats bad also. Anyone with some parts PM me!

  9. #9
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    The driveshaft for a 97 XP is model specific as the XP had two driveshafts.

    PM sent

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,525
    +1
    1,270
    seems like an alignment problem to me..but without seeing the ski..really hard to tell what happened. give the engine a yank/shove to see if the rear mount has cracked

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What happen to my engine. Pic included
    By travis ingram in forum 4-Tec Performance
    Replies: 55
    Last Post: 06-27-2014, 05:32 PM
  2. WTF happened to this Stator on my GP1300r? PICS
    By toddnbrown in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-07-2013, 07:07 PM
  3. What caused the damage to my piston? Pics Inside
    By geoffw in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 08-11-2011, 01:05 PM
  4. WTF happened to my 08 RXP
    By Knottyscotty in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-13-2009, 05:42 PM
  5. What should I do to my hull? Pics on the way!
    By ccassone in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 03-15-2006, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •