Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    505
    +1
    35

    MSX 110 - Is something missing?

    I picked up an MSX 110 in pieces. The previous owner said the motor was seized and had started to disassemble the motor. As it turns out, the pump was seized, but the motor turns freely. I got most of the motor together, but have a little problem. One of the fuel lines isn't long enough to reach the fuel rail. The line does not appear to be altered, and still has the original clamps on it. I'm guessing that there's a part that goes between the fuel line and the fuel rail. There's also an extra connector on the wiring harness (in addition to the connector that goes to the pressure sensor on the intake pipe).

    Can anyone tell me if I'm missing a part?

    Can anyone post a few photos of their motor? It would help to see how everything is hooked up.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	PA070080.jpg 
Views:	117 
Size:	119.3 KB 
ID:	216870  


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,573
    +1
    1,272
    You do know that Polaris Industries has online parts diagrams available - yes?

    Links can be found in the Parts Sources listing from my signature

  3. #3

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    505
    +1
    35
    Quote Originally Posted by K447 View Post
    You do know that Polaris Industries has online parts diagrams available?

    Links can be found in the Parts Sources listing from my signature
    I have the parts manual and the service manual, but can't seem to find the answer. I was hoping someone could just look at their ski and let me know.

  4. #4
    I bought a MSX in pieces and had the same problem. I cut the tie that holds the filter in place and attached the fuel line and has worked fine since.

  5. #5

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    505
    +1
    35
    Quote Originally Posted by fatboyztoyz View Post
    I bought a MSX in pieces and had the same problem. I cut the tie that holds the filter in place and attached the fuel line and has worked fine since.
    That's what I was planning to do. But if you had the same issue, then there must be something missing. There has to be someone out there that didn't get their motor in pieces and can tell us what's missing.

    Do you also have a spare connector on the harness?

  6. #6
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Hi Grumpy,

    The fuel pump may have been turned in the top of the tank? loosen the big plastic ring and re orientate it if it will help. There must have been a shortage of this fuel line because there is only just enough and I do think it shrinks

    The extra connector? which area of the engine?

    Cheers

  7. #7

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    505
    +1
    35
    Quote Originally Posted by Kosh View Post
    Hi Grumpy,

    The fuel pump may have been turned in the top of the tank? loosen the big plastic ring and re orientate it if it will help. There must have been a shortage of this fuel line because there is only just enough and I do think it shrinks

    The extra connector? which area of the engine?

    Cheers
    I thought about turning the fuel pump, too, but that won't make a difference. The too-short segment of fuel line runs from the fuel filter to the fuel rail. The fuel filter is zip-tied into a bracket on the hull and, from what I can tell, it was not touched by the previous owner.

    I posted a better picture showing the extra connector. It only has a few inches of wire, and would only reach somewhere around where I think a part is missing.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	PA080081.jpg 
Views:	88 
Size:	112.1 KB 
ID:	216966  

  8. #8
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Grumpy,

    The lines are tight I don't know what they were like new but all the ones I have seen the fuel filter no longer fits the bracket. It is a bad place ant way the filter will rust through (unless you are in fresh)

    That connector looks like the crankshaft position sensor, this will connect to a lead coming out of the front cover. in under the inter cooler bracket. I will see if I can dig up a picture. breakfast first!

    Cheers

  9. #9
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Pictures
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Poo 3 July 28.09.08 Record 176.jpg 
Views:	64 
Size:	120.8 KB 
ID:	216982   Click image for larger version. 

Name:	Poo 3 Pictures 27.06.08 001.jpg 
Views:	66 
Size:	116.7 KB 
ID:	216983  

  10. #10

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    505
    +1
    35
    Thanks for the pics. I don't see where that extra connector should go. I'll have to look a little more in the light of day.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Polaris msx 110 is it worth fixing?
    By smokeybear in forum MSX/Matrix
    Replies: 3
    Last Post: 06-12-2015, 09:06 PM
  2. My MSX 110 is still messed up
    By notanotherhonda in forum MSX/Matrix
    Replies: 6
    Last Post: 08-23-2009, 01:05 AM
  3. What is the Max RPM, Boost and Speed for 04 MSX 110
    By trx24v in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-18-2008, 03:27 PM
  4. Is something missing from the supercharger
    By razorback88 in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-18-2007, 11:33 PM
  5. 2004 Polaris MSX 110 - is it good?
    By sergiyk in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-05-2007, 05:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •