Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    2003 GTX SC first time out in 2 weeks and it will only go 40 mph

    2003 GTX SC first time out in 2 weeks and it will only go 40 mph last time I used it it was running great over 60 mph and I know it does not have ceramic washer issue only 2004- present.

    But it seems like Supercharger is not kicking in or something that is causing a loss of power.

    I forgot to mention that it was running good when I first took off, but water temp in lake was reading 58 degrees could that have any thing to do with it.

    Also I looked for loose hoses and there is not anything loose or out of ordianary. I did get a maint warning and its the P1202 Any one have any ideas thanks
    Last edited by gregsgp1200; 10-09-2010 at 01:16 PM. Reason: BETTER EXPLANATION


  2. #2

    Join Date
    Jul 2008
    Location
    Peterstown, WV
    Posts
    100
    How many hours? SC could be wore out. Probably the hose came off from the SC.

  3. #3
    castiljd, thanks for response the skio is mint only 70 hours the people I got it from cruised between two lakes in Northern Michigan Burt and Mullet lake. I went out 2 weeks ago and it ran perfect as usual, but yesterday started off like it was fine then I noticed it was not going from take off like it usually does and top speed again only 40 .

    I will check the hose, but I m not familiar with this machine too much, could you point to where it is located, thats what it sounds like something simple.

    I am going to probabaly do a Riva stage 1 kit over the winter, but may get a few more days here this weekend thanks again for you help

  4. #4
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,896
    +1
    506
    Replace the spark plugs!

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by gregsgp1200 View Post

    But it seems like Supercharger is not kicking in or something that is causing a loss of power.

    Greg, If this is the original supercharger then the clutch has probably finally burnt out on it. Those 03 clutches were very prone to slipping. I'm surprised you got 70 hours out of it.

  6. #6
    Green hulk, I thought would it happen gradual or does it happen like the flick of a light switch ? thanks for your response

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    like a flick on those, just pull the intake pipe off the supercharger, if you can turn the turbine wheel with your fingers thats the problem

  8. #8
    Jetskibill9999 thanks I will do that this morning, I guess I will cchange the plugs if that is not it also.

  9. #9
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,896
    +1
    506
    Well how did things come out for ya? Dont leave us hanging man! LOL

  10. #10
    Well, it is not the plugs or the Super Charger, it must be the P1202 issue and I could not find a Seadoo parts place open here where I live, I am going to change both sensors but was hoping someone would be able to tell me and if possible get a photo of the second sensor I think it is in the back. Everything I read is that is the one that cause it to run slow till fixed.

    I did buy a repair manual last night on ebay, buy my warm days here in Michigan could be ending before I get her fixed.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2003 GTX SC full part out
    By tron in forum Sea Doo Classifieds
    Replies: 52
    Last Post: 12-31-2013, 02:34 PM
  2. 2003 GTX SC question for first time owner
    By Jean-Paul in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-25-2010, 01:54 PM
  3. RPM question first time out on green wheel and new prop
    By turbojamie in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-08-2009, 07:10 PM
  4. First time out in two years, any suggestions?
    By Jkunzy1690 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-03-2009, 05:09 PM
  5. First time out in Speedster wake
    By scubascooby in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-09-2007, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •