Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Clutch failure

  1. #1

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19

    Clutch failure

    ok so my clutch has finally let go today at 121 hrs. i have ordered a new one today from the online store. does it come with the oil pipe washers does any one know. i am going to strip it in the morning.....


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by razzie View Post
    ok so my clutch has finally let go today at 121 hrs. i have ordered a new one today from the online store. does it come with the oil pipe washers does any one know. i am going to strip it in the morning.....
    no washers and no gasket.

  3. #3

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    thanks i have e mailed jerry and asked him to add them to my order for me...

  4. #4
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    thought you would have ben covered on warranty..could of swore yours was new..

  5. #5

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    no mine is 2008 one of the very first. sure its out of warranty now mate. had a long chat with mark earlier about doing it. wish it was warranty.

  6. #6
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    121 hard hours......... No clutches disintigrated and pumped through the engine. Id say thats pretty good!

  7. #7
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    whats mods were u running mate? you done a lot better than me lol


    ian

  8. #8

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    Im pretty much same as you ian without the shaft and the R2 my s/c is only C1 tho.

  9. #9

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    Ok so my clutch is now fully stripped and inspected. the inner cage where the sprags is has cracked. there is some signs of wear where the sprags have been biting on the shaft , i assume this small amount of wear has allowed the sprags to turn slightly more than usual causing the cage to crack. hope the new updated ones are stronger which should stop this happening.

  10. #10
    Professional Alike Racer Clazz. Teerayoot's Avatar
    Join Date
    Jun 2010
    Location
    Koa LumPoo!,Thailand
    Posts
    168

    How would possible another reason except clutch failure for RPM no go above 5000?

    i think i can join to post to this thread of my might clutch problem.


    i'm not sure mine clutch went out or not,
    but RPM no go above 5000 and very loud sound from supercharger,
    i have check to spin SC impeller counter clock wise,but cant.

    How would possible another reason except clutch failure for RPM no go above 5000?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger Clutch Failure
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 52
    Last Post: 02-06-2006, 07:38 AM
  2. Is this a clutch failure?
    By kenshin89 in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-15-2005, 09:39 PM
  3. S/C Clutch Failure.
    By Big Red Monster in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2005, 08:22 PM
  4. SC Clutch Failure Sreen?
    By RXDI2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 12:14 PM
  5. Pics of S.C. Gear after clutch failure
    By two2curupt in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-10-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •