Results 1 to 3 of 3

Thread: No spark

  1. #1

    No spark

    My 1998 Seadoo Speedster ran just fine the last time I used it. I has the twin 787's. Today, I got it out to winterize it and couldn't get it to start. It wouldn't even pop once. I pulled a spark plug wire off and found no spark. I checked all the fuses and they are OK. Also, I noticed the gas gauge not working with the power on and the key in place. All the other electronic devices work. Any ideas?


  2. #2
    Try and check all of your fuses.

  3. #3
    gaviski's Avatar
    Join Date
    Oct 2010
    Location
    Port Richey, FL
    Posts
    133
    Quote Originally Posted by reddog View Post
    Try and check all of your fuses.
    He said he did.

    Did it crank? if not, Jump the starter solenoid.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No spark and water temp alarm
    By ybnormal in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-02-2009, 11:02 AM
  2. Engine cranks - but no spark
    By croskel in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-12-2006, 01:36 PM
  3. No Spark Help
    By mt375hp in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-27-2006, 04:07 AM
  4. No Spark ?
    By OsideBill in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-07-2006, 03:27 AM
  5. Uncovered my GTX today, has no spark.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 33
    Last Post: 03-27-2006, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •