Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450

    little disappointed with todays results!!1

    hi i have today been out and the temp was 17 Celsius and i had a full tank of fuel.... all i could get out of the ski was 74.9mph and i was slightly touching limiter at the odd occasion .....what am i doing wrong and what can i do to get 80+ out my set up?



    thanks ian


  2. #2
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Are you still on stock Ride plate? I don't see it listed in your signature.... that is 3+ mph right there. Add an intercooler and you are right there at 80.

  3. #3
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    yep stock plate mate..... will it really gain me that much and also in these cooler temps will a bigger intercooler do much for me?


    thanks ian

  4. #4
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    From what I have read on here, that speed is about right for your mods. What RPM ? You need to get rpm's to go fast. True, the rideplate makes a difference. You can try removing your stock shim plates, then re-shim your stock plate to adjust your speed gains. I did that with my stock plate and gained almost 2mph. I did not like the handling so much, so I went to a modified R&D plate and now I am happy with speed and handling. Read the mod's database at the beginning of the forum to get an idea of where you should be.

  5. #5
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    i think with my mods in our cold climate i should be a lot higher than that...;-(

    thanks ian

  6. #6
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    What rpm are you running Ian ?

    chuck


    Quote Originally Posted by MR MAC View Post
    i think with my mods in our cold climate i should be a lot higher than that...;-(

    thanks ian

  7. #7
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    I think with your mods in your climate should be a bit higher too. However, the rideplate IS holding you back.... the rideplate mod will definitely give you some more speed. Do a stock rideplate shimming "search" for details on how to do it if you don't want to splurge for an aftermarket plate.
    I don't know where you have the trim set, but for me the best top speeds were at 2 clicks up.
    And others will have to chime in about the intercooler and whether or not it will give you an extra 1+ mph to reach your 80 mph goal.

  8. #8
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    And as I think about it....you said you were bumping the limiter which is 8700, so you are definitely turning enough rpm's to be in the 80's with your set up (with a rideplate)...hmmm? Something seems off.

  9. #9
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,130
    +1
    205
    R2 + C3 should be 80+ no problem. What are you using to monitor your RPMs?

  10. #10
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    That is why I questioned his rpm. Something is off there. If he is hitting the limiter, then he should be close to 80, but if he is at 7750, then he is about right with the speed. The reflash should allow plenty of revs, but the speed is off for him to be over 8k rpms.

    Something else too,,,that full tank of fuel will slow him down.


    Quote Originally Posted by gmoeller View Post
    And as I think about it....you said you were bumping the limiter which is 8700, so you are definitely turning enough rpm's to be in the 80's with your set up (with a rideplate)...hmmm? Something seems off.
    Last edited by maxadrenaline; 10-10-2010 at 05:29 PM. Reason: added text

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tested gibson muffler with awesome results today
    By hydrojunkie in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-19-2008, 10:51 PM
  2. Disappointed with Honda...selling
    By guduf4u in forum Honda Open Discussion
    Replies: 35
    Last Post: 09-04-2007, 11:30 PM
  3. Disappointed with "wetherby"-the MFD Repair Guy
    By dorf in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-17-2007, 05:17 PM
  4. Riva stage 3 with rude results
    By bankyf in forum 4-Tec Performance
    Replies: 46
    Last Post: 07-25-2007, 11:06 AM
  5. Little Help with SCIC maintenance!!
    By FLSCIC in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 02-09-2007, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •