Results 1 to 9 of 9

Thread: 2003 GTX 4-tec

  1. #1
    WAVEATER WAVEATER's Avatar
    Join Date
    Nov 2007
    Location
    LAKE DUBAY WISCONSIN
    Posts
    236
    +1
    1

    Unhappy 2003 GTX 4-tec

    I am currently working on a guys GTX. She took in a bucket load of rocks. I need a stock impeller if anyone has one laying around. the plastic sleave in the impeller housing is shot too.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG00279-20101011-1655.jpg 
Views:	88 
Size:	98.0 KB 
ID:	217336   Click image for larger version. 

Name:	IMG00282-20101011-1744.jpg 
Views:	75 
Size:	117.8 KB 
ID:	217381   Click image for larger version. 

Name:	IMG00281-20101011-1744.jpg 
Views:	62 
Size:	113.9 KB 
ID:	217382   Click image for larger version. 

Name:	IMG00280-20101011-1743.jpg 
Views:	52 
Size:	93.6 KB 
ID:	217383  


  2. #2

    Join Date
    Sep 2007
    Location
    Lexington, Ky
    Posts
    1,656
    DAMN!!! Thats a pic for the record books... I have a slew of various different oem props, probably close to a dozen. I'll check some part #'s see if I have one.

  3. #3
    WAVEATER WAVEATER's Avatar
    Join Date
    Nov 2007
    Location
    LAKE DUBAY WISCONSIN
    Posts
    236
    +1
    1
    Thats awesome! Thx boost!

  4. #4
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    You wll probably have a hard time finding a new wear ring, and I would say an OEM 185 prop, but if anyone has one, its Chris (Boostaholic).

    It looks like, to me, some of the rocks in picture 1 were jammed in from the back of the pump. I'm not making any assumptions, just noting the quantitiy of rocks and how far they got through the pump.

  5. #5
    WOW!!! now is the time to install the aluminum pump, it was an upgrade back when...

    def need to repair that tunnel... and is the ski sitting on the ground? what`s with all the grass and leaves?...lol...

  6. #6
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Maybe pulled up on shore to remove rocks, etc?!

    +1 on metal pump.

  7. #7
    WAVEATER WAVEATER's Avatar
    Join Date
    Nov 2007
    Location
    LAKE DUBAY WISCONSIN
    Posts
    236
    +1
    1
    yea I've been servicing ski's a long time and thats the worst I've seen. But believe it or not they were all sucked in, and judging by the sand blasting, or should I say rock blasting the pump tunnel took it didn't get shut down immediately. The "P" gravel was just small enough to fit throught the factory intake grate and impeller and just large enough to get stuck in the vanes on the way out.
    Quote Originally Posted by jpeconsult View Post
    You wll probably have a hard time finding a new wear ring, and I would say an OEM 185 prop, but if anyone has one, its Chris (Boostaholic).

    It looks like, to me, some of the rocks in picture 1 were jammed in from the back of the pump. I'm not making any assumptions, just noting the quantitiy of rocks and how far they got through the pump.

  8. #8
    WAVEATER WAVEATER's Avatar
    Join Date
    Nov 2007
    Location
    LAKE DUBAY WISCONSIN
    Posts
    236
    +1
    1
    Hey Andy, it's been awhile, how have ya been? yea I'm going to get some marine tex and repair the tunnel, stronger than glass and more sandable than 5200 F.C. yea i wondered on the grass to, but it looks like the lawn was getting cut past the ski, and his trailer really sits low to the ground, I had it on a floor jack when I took the pics. Will have to consider the pump upgrade, not my machine but a friends, will see what he wants to do.
    Quote Originally Posted by Pale Rider View Post
    WOW!!! now is the time to install the aluminum pump, it was an upgrade back when...

    def need to repair that tunnel... and is the ski sitting on the ground? what`s with all the grass and leaves?...lol...

  9. #9
    pass1's Avatar
    Join Date
    Apr 2009
    Location
    Gatineau, Canada
    Posts
    423
    +1
    5
    Not to hijack the thread but... got a friend that his plastic housing pump is gone too, is installing a aluminium housing just a matter of putting a 155 wear ring and impeller and call it a day??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2003 GTX 4-tec Cylinder Head
    By 8 is enough in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 02-08-2011, 08:27 PM
  2. FS 2003 GTX 4-Tec Van's Edition w/ 98 Hours - $1200
    By seatsR4toilets in forum Sea Doo 4Tec Skis
    Replies: 4
    Last Post: 06-15-2010, 04:57 PM
  3. FS 2003 GTX 4-Tec Van's Edition w/ 95 Hours - $1500
    By seatsR4toilets in forum Sea Doo 4Tec Skis
    Replies: 1
    Last Post: 05-02-2010, 09:15 PM
  4. Looking for 2003 GTX 4 tec ecu, Non Supercharger
    By blackrxp in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-30-2009, 11:05 AM
  5. 2003 GTX 4 TEC/SC pump problems
    By HD RACING in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-02-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •