Results 1 to 2 of 2
  1. #1

    Starting Problems

    My 2000 Yamaha 800 XL was running fine until the last time I tried to start the ski. The starter spins but does not engage or turn the engine and the dash lights do not light up when I insert the key or press the start button. I pulled the starter out and it checks out fine, so I replaced the starter solenoid and checked the battery - same reaction when I try to start the ski.

    Where do I start next trying to find the problem. Any help will be appreciated.


  2. #2
    Probably your Bendix drive... the issue comes up a LOT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Genesis starting problems
    By prairie water in forum Polaris Open Discussion
    Replies: 13
    Last Post: 07-24-2008, 01:02 AM
  2. Starting Problems
    By Monkeyman22 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-26-2008, 06:44 PM
  3. Starting problems
    By RXP_Noah in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-11-2008, 07:37 PM
  4. gpr starting problems
    By boconnor811 in forum Yamaha How To & FAQs
    Replies: 7
    Last Post: 07-26-2007, 07:42 PM
  5. Starting Problems
    By bryan428 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-19-2007, 09:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts