Results 1 to 7 of 7
  1. #1

    Join Date
    Oct 2010
    Location
    miami
    Posts
    38

    Need an expert advise on this drive shaft!!!

    remove the driveshaft out of my 06 seadoo spotster 215hp, story is i broke two motor mounts heard a grinding noise and now motor over revs but wont move in the water. how bad is it to get that output sleeve out.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_4417.jpg 
Views:	57 
Size:	29.7 KB 
ID:	218070   Click image for larger version. 

Name:	IMG_4420.jpg 
Views:	48 
Size:	53.1 KB 
ID:	218071  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    What do the splinds in the prop look like

  3. #3

    Join Date
    Oct 2010
    Location
    miami
    Posts
    38
    [/IMG][/IMG]

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Ouch... you definitely need to replace that PTO

  5. #5
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Thats anoying....

    Is it a full PTO exchange sort of deal or just the shaft section?

  6. #6

    Join Date
    Oct 2010
    Location
    miami
    Posts
    38
    yeah the grinding noise i heard was the shaft grinding on the output sleeve, any one has instructions on how to change the sleeve can this be done with the pto cover on. this is just the shaft right? do you think i can salvage the prop,

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Yep... you need part # 10. Also replace # 9 & 11 while your at it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does this drive shaft need to be replaced?
    By imp0ster in forum 4-Tec Performance
    Replies: 15
    Last Post: 01-25-2013, 08:19 AM
  2. Replies: 1
    Last Post: 07-08-2010, 03:38 PM
  3. Drive Shaft ..Gap? Need an Expert opinion.
    By finncolors in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-08-2009, 06:55 PM
  4. Is this drive shaft too far gone?
    By Therock in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-20-2007, 11:16 PM
  5. Need Advise on this. Ingested some water and now problems.
    By Water4fire in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-21-2005, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •