Results 1 to 6 of 6

Thread: More Newby Help

  1. #1

    More Newby Help

    Once again just want to thank you guys in advance for your previous help and comments, I might make a waverunner mechanic after all.

    I just removed my jetpump and housing to replace the wear ring and had some questions so I stopped short of reassembly. The bearings in the pump feel good and tight and the ring was somewhat worn looking. Also the impeller is rough on most of the edges. Is this normal? will it greatly affect performance? or do I need to replace or just put it back together. If a replacement is the way to go I've been reading and some say go 13/19 solas on the pitch. My ski is mainly stock, fresh motor(2 hours) airbox removed, d-plate, intake grate and plate on the way, carbs are going to oside bill in a week or so and shoe plug mod.. The only other mod I have considered is sending off the head to be milled. I don't want to over prop and have to take it all apart again so your help will be greatly appreciated. Also been reading the instructions for reassembly, do you use the yamahbond between the wear ring housing and the pump housing? Or between the pump and transom? Or both? not sure and like I said duplication of effort while important for learing, I would like to avoid.


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,501
    +1
    619
    can you post the prop edges so the tuners and gurus can judge the condition...

  3. #3
    here are some pics, I don't know if this is normal wear or not or how much it will degrade the performance. Just replacing the wear ring, there is a photo of the old one, what should the clearance between the impeller and ring be? and does the impeller look ok?Click image for larger version. 

Name:	IMG_1011.jpg 
Views:	66 
Size:	64.1 KB 
ID:	218218Click image for larger version. 

Name:	IMG_1008.jpg 
Views:	69 
Size:	79.6 KB 
ID:	218220Click image for larger version. 

Name:	IMG_1007.jpg 
Views:	69 
Size:	84.4 KB 
ID:	218217

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by yamaha_2000r6 View Post
    here are some pics, I don't know if this is normal wear or not or how much it will degrade the performance. Just replacing the wear ring, there is a photo of the old one, what should the clearance between the impeller and ring be? and does the impeller look ok?Click image for larger version. 

Name:	IMG_1011.jpg 
Views:	66 
Size:	64.1 KB 
ID:	218218Click image for larger version. 

Name:	IMG_1008.jpg 
Views:	69 
Size:	79.6 KB 
ID:	218220Click image for larger version. 

Name:	IMG_1007.jpg 
Views:	69 
Size:	84.4 KB 
ID:	218217
    Both need to be changed you can see the liner has blistered and the impeller is already hitting it, And you can see bad cavitation on the impeller edges also.

  5. #5
    Thanks so much for the help Jim, as I said waverunners are new to me and just don't want to end up doing something twice cause I didn't do the right thing the first time. I have seen it on here somewhere but now can't find the link. Where is the best place to get the impeller tool for removing the stock one? And anyone have a stock or concord impeller and housing they can part with?

  6. #6

    Join Date
    Jan 2006
    Location
    Texas City, Texas
    Posts
    1,249
    +1
    15
    Quote Originally Posted by yamaha_2000r6 View Post
    Thanks so much for the help Jim, as I said waverunners are new to me and just don't want to end up doing something twice cause I didn't do the right thing the first time. I have seen it on here somewhere but now can't find the link. Where is the best place to get the impeller tool for removing the stock one? And anyone have a stock or concord impeller and housing they can part with?
    You have a PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. more newbie problems HELP!
    By pslt780 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-20-2009, 04:37 PM
  2. newbie help slow gp1300
    By steve's1300gpr in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 06-11-2007, 01:15 PM
  3. newbie help slow gp1300
    By steve's1300gpr in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-11-2007, 12:37 PM
  4. Yamaha Gp1300R newbie! Help.
    By jesperducati in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 04-17-2007, 05:20 PM
  5. Newbie Help
    By golson in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-13-2006, 09:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •