Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,142
    +1
    255

    Question Need Help with Ride Plate

    i recently got a R&D ride plate with Jim's cut i have a 09 SHO and i do more ocean riding than lakes and canal, so here's my question

    How would it work better for me, how many SHIMS on FRONT and BACK please ?


  2. #2
    I have had good luck with 2 shims in the back ( Near the Pump ) and no shims up in the front ( Near intake Grate ). R&D Ride Plate. It seems to keep me hooked up...

  3. #3

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Quote Originally Posted by coby45 View Post
    I have had good luck with 2 shims in the back ( Near the Pump ) and no shims up in the front ( Near intake Grate ). R&D Ride Plate. It seems to keep me hooked up...
    +1.

  4. #4
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,142
    +1
    255
    thanks i will try ur setup

  5. #5
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    Quote Originally Posted by coby45 View Post
    I have had good luck with 2 shims in the back ( Near the Pump ) and no shims up in the front ( Near intake Grate ). R&D Ride Plate. It seems to keep me hooked up...
    on a sho or fz ??

  6. #6
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,142
    +1
    255
    Quote Originally Posted by 305coco View Post
    on a sho or fz ??
    sho, you sold me ur blow off coco

  7. #7
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,795
    +1
    2,010
    Assuming yours is cut the same as mine, you really can't shim the front of Jim's R&D plate without causing it to hang below the transom plate, which will scrub speed. However, there's plenty of angle to play with, so there's really no reason you'd need to shim the front anyway. 2-3 .045" shims under the back is a good place to start. Since you're using an R&D grate you can run a little more angle on the plate before getting a buck than you can with a Riva grate, but be careful, if you go too far it WILL buck on you.

    FYI, it's not a good idea to do what you're doing in your avatar with washer style shims under the plate on these nanoX hulls. It puts a whole lotta force on a small surface area of hull & the shims can crush through.

  8. #8
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,142
    +1
    255
    thanks for the advice mjh3idesi will keep that in mind, and i will try no shims on front and two shims on the back

  9. #9

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Quote Originally Posted by mjh3ides View Post
    FYI, it's not a good idea to do what you're doing in your avatar with washer style shims under the plate on these nanoX hulls. It puts a whole lotta force on a small surface area of hull & the shims can crush through.
    Very good point and we have a mutual friend that has wave jumped and seen this happen.

  10. #10
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,142
    +1
    255
    thanks again , so i will enjoy this last weekend of wave jumping, after plate is on, no more waves

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 07-22-2013, 10:17 PM
  2. Replies: 9
    Last Post: 07-21-2010, 09:19 AM
  3. Help With Ride Plate - 05 STXR
    By BadBowtie03 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-14-2010, 02:06 PM
  4. need help with ride plate!!!
    By N8T in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-29-2009, 01:46 PM
  5. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •