Results 1 to 7 of 7
  1. #1

    99 gsx limited hold starter button runs -let go stops-

    I HAVE A GOOD ONE, 1999 GSX LIMITED THE SKI STARTS AND RUNS AS LONG AS I HOLD THE STARTER BUTTON DOWN.I LET UP ON THE BUTTON IT SHUTS OFF.I REPLACED THE MEPM STILL DOES THE SAME THING.I REPLACED THE STATOR AND PICK-UP DOES THE SAME THING.I REPLACED THE STARTER BUTTON DOES THE SAME THING.AS LONG AS I AM PUSHING ON THE RED BUTTON IT RUNS FINE.I GET 2 BEEPS WHEN I PUT THE LANYARD IN.ALL THE GAUGES WORK FINE.I AM OUT OF IDEAS. CAN ANYONE GIVE ME SOME ADVISE OR HELP PLEASE THANKS KEITH MY CELL 6103926065


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by keith neff View Post
    I HAVE A GOOD ONE, 1999 GSX LIMITED THE SKI STARTS AND RUNS AS LONG AS I HOLD THE STARTER BUTTON DOWN.I LET UP ON THE BUTTON IT SHUTS OFF.I REPLACED THE MEPM STILL DOES THE SAME THING.I REPLACED THE STATOR AND PICK-UP DOES THE SAME THING.I REPLACED THE STARTER BUTTON DOES THE SAME THING.AS LONG AS I AM PUSHING ON THE RED BUTTON IT RUNS FINE.I GET 2 BEEPS WHEN I PUT THE LANYARD IN.ALL THE GAUGES WORK FINE.I AM OUT OF IDEAS. CAN ANYONE GIVE ME SOME ADVISE OR HELP PLEASE THANKS KEITH MY CELL 6103926065


    That is a good one. Im kinda going out on a limb here with this but maybe you have a bad or multiple bad grounds on the engine somewhere and by holding down on the switch you are creating an alternate path to ground for the ignition system. It could even be loose pin tension somewhere that provides ground. Funny things can happen when you loose a ground. Circuits will back feed trying to find some where to go. The schematics do not show the internal paths to the mpem so it makes it hard to see how it could happen. Anyway, just trying to throw some food for thought that doesn't involve replacing something.

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    It is a bad TPS switch on the throttle cable,try unplugging it & see if it starts right.

  4. #4

    water work your the man

    thank you so much for your help your the man starts and runs next question do i need to replace the throttle cable or just let it un plugged?i would think it should be replaced thanks again keith

  5. #5
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    You need to replace the cable.

  6. #6
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    I have one for a XPL but it is different than the GSX one & the price is not cheap !!!!

  7. #7
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by water worx View Post
    You need to replace the cable.


    Is TPS not looked at while cranking then then once fired the mpem looks to it? Does holding the button make the mpem think the engine is still being cranked?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 99 GSX Limited hood with Working Guages
    By Joe Stang in forum Sea Doo 2 Stroke Skis
    Replies: 4
    Last Post: 10-06-2009, 10:28 AM
  2. starter issues 99 gsx limited
    By 1fastrat in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-13-2008, 09:35 PM
  3. 99 gsx limited mpem needed
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-09-2008, 02:42 PM
  4. 99 gsx limited top end and oil pump
    By pooch96xp in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-09-2008, 04:00 PM
  5. 99 gsx limited mid range bogg
    By PRIME in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-23-2007, 03:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •